# Launch pvserver using .pvsc on Windows

**URL:** https://discourse.paraview.org/t/launch-pvserver-using-pvsc-on-windows/7959
**Category:** ParaView Support
**Created:** [September 8, 2021, 3:39pm UTC](https://discourse.paraview.org/t/launch-pvserver-using-pvsc-on-windows/7959 "2021-09-08T15:39:45Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![woodscn](https://discourse.paraview.org/user_avatar/discourse.paraview.org/woodscn/32/3226_2.png) [@woodscn](https://discourse.paraview.org/u/woodscn)
#### Post date: [September 8, 2021, 3:39pm UTC](https://discourse.paraview.org/t/launch-pvserver-using-pvsc-on-windows/7959/1 "2021-09-08T15:39:45Z")

</div>

I’m attempting to launch a pvserver and connect to it on a Windows machine, following the guide here: [ParaView:Server Configuration - KitwarePublic](https://www.paraview.org/Wiki/ParaView:Server_Configuration). Unfortunately, the process fails with the following error:

```auto
critical: In unknown, line 0
critical: The process failed to start. Either the invoked program is missing, or you may have insufficient permissions to invoke the program.
critical: In unknown, line 0
critical: Command launch timed out.

```

Does anyone have experience getting this to work on Windows? Running Paraview as Administrator doesn’t seem to help, and would be a problem anyway.

[test.pvsc](https://discourse.paraview.org/uploads/short-url/cbbElQzVcBaDq42hqdBJryhvZPv.pvsc) (725 Bytes)

---

<div class="post-metadata">

### Author: ![mwestphal](https://discourse.paraview.org/user_avatar/discourse.paraview.org/mwestphal/32/17_2.png) [@mwestphal](https://discourse.paraview.org/u/mwestphal)
#### Post date: [September 8, 2021, 3:55pm UTC](https://discourse.paraview.org/t/launch-pvserver-using-pvsc-on-windows/7959/2 "2021-09-08T15:55:46Z")

</div>

Are you able to run this from a command line ?

`C:\Program Files\Paraview 5.9.1-MPI-Windows-Python3.8-msvc2017-64bit\bin\pvserver.exe`

---

<div class="post-metadata">

### Author: ![woodscn](https://discourse.paraview.org/user_avatar/discourse.paraview.org/woodscn/32/3226_2.png) [@woodscn](https://discourse.paraview.org/u/woodscn)
#### Post date: [September 8, 2021, 4:02pm UTC](https://discourse.paraview.org/t/launch-pvserver-using-pvsc-on-windows/7959/3 "2021-09-08T16:02:40Z")

</div>

I have to enclose it in single-quotes and add some Windows-isms:

```auto
PS C:\Users\WOODCN2> & 'C:\Program Files\Paraview 5.9.1-MPI-Windows-Python3.8-msvc2017-64bit\bin\pvserver.exe'
Waiting for client...
Connection URL: cs://INL616346:11111
Accepting connection(s): INL616346:11111

```

I don’t seem to be able to just plug that same sequence into the .pvsc file, though. This yields the same error, for instance:

`<Command exec="&amp; 'C:\Program Files\Paraview 5.9.1-MPI-Windows-Python3.8-msvc2017-64bit\bin\pvserver.exe'"`

So does this (using the cmd syntax):  
`"C:\Program Files\ParaView 5.9.1-MPI-Windows-Python3.8-msvc2017-64bit\bin\pvserver.exe"`

---

<div class="post-metadata">

### Author: ![pavel](https://discourse.paraview.org/user_avatar/discourse.paraview.org/pavel/32/8287_2.png) [@pavel](https://discourse.paraview.org/u/pavel)
#### Post date: [December 30, 2021, 9:54am UTC](https://discourse.paraview.org/t/launch-pvserver-using-pvsc-on-windows/7959/4 "2021-12-30T09:54:16Z")

</div>

Hello Nathan,

If it is still actual, you can add ‘C:\Program Files\ParaView 5.9.1-MPI-Windows-Python3.8-msvc2017-64bit\bin’ to path variable on your Windows machine, restart ParaView client, and then use the following .pvsc file:

```auto
<Servers>
    <Server name="case6_modified" resource="cs://localhost">
        <CommandStartup>
            <Options>
                <!-- The user chooses the port on which to start the server -->
                <Option name="PV_SERVER_PORT" label="Server Port: ">
                    <Range type="int" min="1" max="65535" step="1" default="11111" />
                </Option>
            </Options>
            <Command exec="pvserver -sp=$PV_SERVER_PORT$" delay="5">
            </Command>
        </CommandStartup>
    </Server>
</Servers>

```

Hope it helps you.

Best Regards,  
Pavel
