# Paraview-Glance The need for live server

**URL:** https://discourse.paraview.org/t/paraview-glance-the-need-for-live-server/6690
**Category:** Web Support
**Created:** [March 13, 2021, 6:28am UTC](https://discourse.paraview.org/t/paraview-glance-the-need-for-live-server/6690 "2021-03-13T06:28:05Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![devngc](https://discourse.paraview.org/user_avatar/discourse.paraview.org/devngc/32/5514_2.png) [@devngc](https://discourse.paraview.org/u/devngc)
#### Post date: [March 13, 2021, 6:28am UTC](https://discourse.paraview.org/t/paraview-glance-the-need-for-live-server/6690/1 "2021-03-13T06:28:05Z")

</div>

Hi,

I built a local instance of Paraview-Glance and edited the interface. Only made changes in the glance.f7a92c46baf3e424c5b4.js.

When I try to load files I see this error.

```
glance-external-Workbox.878508a61ecced2e9e96.js:1 Workbox service worker failed to register TypeError: Failed to register a ServiceWorker: The URL protocol of the current origin ('null') is not supported.
    at glance-external-Workbox.878508a61ecced2e9e96.js:1

```

If I fire up a live server, everything works and I don’t see the error.

**Why do I need a live server here when I have built a local instance and I have all the necessary files available locally?**

 ![build](https://discourse.paraview.org/uploads/default/original/2X/2/28fe3c8396599852afc26387d28f4d0d9b01545b.png)

---

<div class="post-metadata">

### Author: ![Forrest\_Li](https://discourse.paraview.org/user_avatar/discourse.paraview.org/forrest_li/32/1935_2.png) [@Forrest\_Li](https://discourse.paraview.org/u/Forrest_Li)
#### Post date: [March 15, 2021, 2:38pm UTC](https://discourse.paraview.org/t/paraview-glance-the-need-for-live-server/6690/2 "2021-03-15T14:38:38Z")

</div>

Hi,

Service workers only run over HTTPS. Ideally Glance should detect that the worker is not loaded and fall back gracefully, but if that is not the case then please open an issue on the Github issue tracker so we can track and fix this.
