# Paraview web inside docker container

**URL:** https://discourse.paraview.org/t/paraview-web-inside-docker-container/8136
**Category:** Web Support
**Created:** [October 7, 2021, 8:22am UTC](https://discourse.paraview.org/t/paraview-web-inside-docker-container/8136 "2021-10-07T08:22:57Z")
**Posts on this page:** 1
**Showing post:** 8

<div class="post-metadata">

### Author: ![rasunag27](https://discourse.paraview.org/user_avatar/discourse.paraview.org/rasunag27/32/4636_2.png) [@rasunag27](https://discourse.paraview.org/u/rasunag27)
#### Post date: [October 26, 2021, 7:13am UTC](https://discourse.paraview.org/t/paraview-web-inside-docker-container/8136/8 "2021-10-26T07:13:23Z")

</div>

Hi Drew,  
Based on your suggestion, I have made two docker images, one which gets me the vtk file and other for visualization.

But for visualization, I have done the following process.

a. Copied pv-5.9.0 and pvw contents which relates to launcher and start.sh file to docker container.  
b. Run apache2 along with start.sh file  
c. Run the docker with exposing network port to 80 as docker run -p 8080:80.  
d. The path is working good with `http://localhost/lite/?data=/dir`, but when I click `connect to paraview`, I get error stating  
`Session did not start before timeout expired. Check session logs.`

I checked with error log in pvw/logs, where an error mentioned as `Segmentation fault with Loguru expection occurance`.

I went through this issue [loguru issue](https://discourse.paraview.org/t/troubleshooting-core-dumps-in-ubuntu-18-04/5601) and found that the `vtkXOpenGL` doesn’t work in cloud.

I tried working with Osmesa 5.9.0 version. The log file shows:

```auto
wslink: Starting factory
CRITICAL:twisted:wslink: Starting factory

```

Now also, I am getting the same error.

Any work around needs to be done?

Regards,  
Sunag R A.

---

_[View the full topic](https://discourse.paraview.org/t/paraview-web-inside-docker-container/8136)._
