Volume of vtkImageData does not render

Hello,

I’m a paraview beginner and have been having some issues with volume rendering.
I have made a ProgrammableSource that reads some files, does a bit of pre-processing then creates a vtkImageData with timesteps. This displays just fine when using Wireframe:

But for some reason when using the Volume, nothing renders:

What bugs me is that when left clicking to rotate the view, I still get a weird preview (which disappears as soon as I stop rotating the view):

I have attached the first frame of the cube exported as pvd format:
frame1.pvd (284 Bytes)

I would be extremely grateful if there was something obvious that I missed. Thanks for any help !
Regards

— Setup

  • Client:
    Paraview: 5.9.1-1209
    Debian GNU/Linux 10 (buster)

  • Server (pvserver):
    Paraview: 5.9.1-1209-egl-mpi
    RHEL 7.7
    GPU: Quadro GV100

pvd file alone is not enough, please share the actual file (vti)

Thanks for the quick response. I hope I’ve done it right this time. I linked it on a drive because the file size is around 50Mb

https://drive.google.com/file/d/1VETpUpLJFbO3mghJNhibsChY19Z4kO_V/view?usp=sharing

file is not shared

My bad. Should be the case now

I’m able to reproduce but not sure what is going on, more investigation would be needed.

1 Like

Thanks a lot. Should I ask somewhere? Feel free to ask if I can help in any way

Unless someone from the community picks it up, your best bet is with profesionnal support from Kitware:

1 Like

Alright. Thanks

I have actually found some sort of workaround: By reducing the size of the matrix (by around /8), it eventually did start showing up normally. My guess would be that there is an upper limit to the size of what Paraview can handle. I’ll stick to that for now, we don’t need this resolution (yet)

Sounds like a bug.

You seem to have a decent NVIDIA GPU so I suggest you try to load the NVIDIA IndeX plugin and use its volume rendering engine which is much faster and more capable. Your example worked for me with IndeX out-of-the-box.

1 Like

This looks promising, thanks.
I was running the latest nightly for debug which segfaults with Nvidia IndeX but I’ll retry with the stable version.