Complete compilation of Paraview (Readers+OSmesa+Python)


FYI, that option generated a warning

-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:


Oh, I see the ParaView 5.10.1 tag above now. Are you trying to build ParaView master with the 5.10.1 tag of the superbuild?

I am building the 5.10.1 tag from superbuild rather than master so that I have a reproducible scenario.

I did the git submodule init and update

The tagged version in superbuild should pull in the correct version combination of dependency for the correct build right ?

What is the paraview_SOURCE_SELECTION for your build?

It is set to git


I see that it has other options like source and 5.10.1

I should override with 5.10.1 ?

Yes, otherwise you’re getting master.

We should document that, if not already,

The problem is that the versions.cmake default was never changed. Something is missing in the release checklist to change that for the release branch. @vbolea @cory.quammen

1 Like

Hi @ben.boeckel

I am happy to report that for the qt build + install, the following works

I have also launch paraview and tested with wavelet source and some volume rendering.

cmake \
    -D ENABLE_catalyst=OFF \
    -D ENABLE_qt5=ON \
    -D ENABLE_python3=ON \
    -D ENABLE_mpi=ON \
    -D ENABLE_paraview=ON \
    -D paraview_SOURCE_SELECTION=5.10.1 \
    -D CMAKE_INSTALL_PREFIX=$HOME/systems/ParaView/5.10.1-qt \
    -D CMAKE_BUILD_TYPE=Release \
    -G Ninja \

I am proceeding to repeat this with osmesa and will report back here