Achieving left-handed axes (z down, x right, y in)

Hey all, I am trying to plot a velocity field of the subsurface in geophysical standards, which is a left-handed axis, i.e. z positive downwards, x positive to the right, and y positive inwards. The thing is Paraview uses right-handed axes by default. After loading the raw data, I tried applying filter->Transform with a rotation of 180 of the third axis and translation of zmax (1400) on the first axis (because the whole block moved down from the z-axis after rotation). The thing is that my Z-axis was supposed to be from 0 to 1400, but it is 1400 to 0. Any tips on what to try?


If you can live with a visualisation in a right-handed system, you could just scale the z-coordinates with -1. That is what I do with my geophyiscal data (which is not always in the left-handed system, depending on the software…).
If you then want axis labels matching the expectation of the viewer (left-handed system), you can use the Axes Grid, in the advanced settings (gear icon) use Data Scale (Z) = -1. Only the Orientation Axis might be confusing then, so you might want to discard it for your visualisation.

Dear Venke,

I believe this is the cleanest solution (only two steps), thanks!
Just for clarity for future readers, on filter->Transform, my first step of rotating the 3rd axis by 180 and translating the first one by zmax is equivalent to using Scale=-1 on the first (z) axis. Both achieve the desired orientations of xyz, but have the problem of the z-axis displaying zmax to zmin.
This is fixed by the second step which is setting Data Scale(Z) = -1 on the Axes Grid window.
Awesome, thanks again :smiley: