Animate a steady state scene

I’ve got some OpenFOAM data from a steady state run. The model ran for 271 iterations to converge, although doesn’t seem to have saved the data for all the prior steps, only the final one, which is fine, as this is the one that it’s converged by so the previous ones aren’t very useful anyway. However when I try to do an animation (just trying to animate a camera pan and moving the seed points of a steam tracer), then it insists on trying to animate the whole sequence from step 1, so I basically get an animation consisting of just the grey geometry without any colouring or streamlines, which only briefly flash up on the final frame. So how can I set this up to apply all the animations to all be applied to the final time step? I’m using version 5.12.0-RC1 on Linux, so the animation toolbar seems to have been replaced by the Time Manager toolbar. I’ve set up my camera panning and line source moving on this, but I can’t get the timing to work. I’ve tried unchecking the box on Time Sources, setting a number of frames and setting the time period from 270.8 to 270.9 (as seen in the screenshot) as I thought this should then make 20 frames all of the 271st step, but this just saves a video that is 1 frame long!
Also it takes a very long time to make the animation as it seems to be trying to reload the data every time, is there a way to speed this up as it’s the same data being used each time?

Hi @trilbytim

Please share your data.


Hi there, here is the data, and the “view.pvsm” file in the root folder is my attempt at animating it:

I’ve tried with version 5.6 as well, which does have an Animation Manager window rather than a time manager window. This seems to work, but when I watch the video the first few seconds are good, then it freezes for the rest of the clip before jumping to show the last frame.

You can uncheck the timekeeper or use a ForceTime filter to avoid that.

I already tried unchecking the “Time Sources” but then it just outputs a video 0 seconds long consisting of a single frame (regardless of the value in the “Number of frames” box). I have now tried adding a ForceTime filter, I’ve added it to the OpenFOAMReader1 object and have added it to the Time Manager window, I’ve tried various settings but I can’t find any way to get it to produce a video with more than 1 frame!

You need to set the Frame Window in the Save Animation dialog, in the advanced option.

  • File → SaveAnimation
  • Press the cogwheel
  • Set the frame window max to 300
  • Save

This should be done automatically though.

1 Like

FYI @nicolas.vuaille

Thank you, that does now work. Although it seems to be re-reading the data for every frame. Since the only things changing between frames are the camera angle and the stream tracer it would be much quicker if it didn’t do this. Is there any way to stop it from re-loading the data every time?

Yes, uncheck the timekeeper in the advanced property of the time manager.

1 Like

Excellent! Thank you so much. I had assumed that unchecking the “Time Sources” would do this, I hadn’t realised that there was also a ‘timekeeper’ under the animations heading. That’s now rendering much faster.

1 Like

Indeed, the Time Keeper is the track that updates the pipeline with the time from the Time Sources.

So to animate only properties / camera without changing the current timestep of the pipeline, one should:

  • go to the targeted time step
  • disable the TimeKeeper ( in Time Manager view, advanced mode)
  • disable the TimeSources
  • configure the number of wanted frames
  • create some animation tracks
1 Like