Annotation Attribute Data error

I have a model with some data array, for example “Dynamic//Displacements”.
I know that this data array exists and it is correct because I can draw it


However when I try to create an AnnotateAttributeData filter and I select any data array, for example “Dynamic//Displacements” the following error appears:

I thought this error was caused because my data array has different components, but I have tried the same with scalar data arrays and the same error happens.

please share your data

I have attached the file of the first step

Ramseries-Mono_NodesSet_Dynamic_0.vtu (40.8 KB)

The slashes in the name are causing the issue. You can rename your arrays using the RenameArrays filter (or Calculator if not available).

In any case, this is a bug, please open an issue on our gitlab:

Thank you.

I have opened an issue on your gitlab.


I’m sorry but I don’t understand what Cory Quammen said. Are they instructions for a programmer or for me?

These are instructions for the programmer that will try to fix the issue. do not worry :slight_smile:

Ok thank you very much for your attention