Black background with volume rendering

When I use volume rendering of the velocity data set, the background becomes black and I can’t find a way to change the background color. Please see the attached image as an example.

Seems like it’s the same error that has been fixed, but I still experience the same issue.

PC : Mac Book Pro with Apple M1 Pro chip
OS : macOS Ventrua 13.0
Paraview version : tried both 5.10.1 and 5.11.0

Link to the data set: velocity_save_deg_1.xdmf - Google Drive, velocity_save_deg_1.h5 - Google Drive

Unabled to reproduce on Linux.

Probably a graphic driver issue.

Thank you for the answer! Does that mean there’s no way to fix this issue at the moment rather than using Linux or other graphic driver?

You could try playing with the Volume Rendering parameters under the Display section of the Properties panel. In particular, you might try turning off the Use Floating Point Frame Buffer option.

Screen Shot 2023-02-13 at 10.16.51 AM

You may also try changing the type of volume renderer used by using the Resample To Image filter. This could reduce the quality of the image, though.



Turning off the Use Floating Point Frame Buffer worked! Thank you for your suggestion.

This is not git bug 20556, which was having intermittent black frames. This is bug, which has been an issue with Macs for ever. There was even an older bug written up, but I couldn’t find it.
Thanks Ken for explaining a workaround. I am sure that will help Kitware debug and fix this one.

Yes indeed I think that is a bug for the mac user all the time. I also have this issue for many different versions. I hope that Kitware can debug and fix this one. Thanks!