Bug with Temporal Interpolator filter

I already made a topic in Support thinking it could be solved easily, but I investigated a bit more and it seems to be an issue with the Temporal Interpolator filter when reading a HDF5 file (through xdmf). After a few timesteps it completely corrupts the geometry, but doesn’t crash or return any error :

I tried the different xdmf readers, with different results, but it always ends up corrupting the geometry. My data seems fine, and hasn’t generated any other errors so far.

Here is my data.

TemporalInterpolator expect your Point IDs to not change overtime, looks like they do.

I would be surprised as all my timesteps point to the same mesh in the HDF5 file. Maybe there is a way to check this.

Also this would not explain why it works fine with vtu files of the same data.

I just tried your data, TemporalInterpolator seems to be working fine.

Please provide steps to reproduce.

I’m using ParaView 5.11.2 on Ubuntu 22.04.4. Here are the steps :

  1. Open xdmf file with Xdmf3ReaderS (tried the others too with the same result) and Apply.
  2. Apply TemporalInterpolator to it, and choose any resample factor >1 (tried 2, 5, 10 and 100).
  3. Click play. It will go through a few timesteps with no problem then the geometry will disappear, or change position, or completely collapse.

A colleague tried on his data with ParaView 5.12 RC3 and got the same result.

I confirm the issue with the Xdmf3Reader, but not with XdmfReader.

Indeed I was mistaken, the issue with the XdmfReader is different : the fields are not consistent anymore. The Pressure field for example changes unexpectedly, without even the TemporalInterpolator, that is why we discarded this option right away.

please open issues in https://gitlab.kitware.com/paraview/paraview/-/issues

1 Like