Build paraview 5.11 with VISIT Bridge on ubuntu

I use paraview5.11 on windows and it works flawlessly with my tecplot files as it comes all setup with the VisIT readers. I want to achieve the same on an ubuntu machine. However, the default ubuntu comes with only paraview 5.4 and I can’t update it simply via sudo apt-get. So, I realized I’ll have to build it manually. I found this documentation and used it for installation. I must also mention that I had to manually specify my qt5 directory and this post helped me out in that regard:

After doing all this, although I could build a version of paraview that launched and worked as it should, it didn’t contain the VisIT bridge by default. I know that because the readers don’t show up while opening files and my tecplot files that open completely fine on my windows installation, fail to open in this build. So, I thought I’ll add the option -DPARAVIEW_USE_VISITBRIDGE=ON in the cmake command along with other options, but the output ends with:
“CMake Warning:
Manually-specified variables were not used by the project: PARAVIEW_USE_VISITBRIDGE”.

Could someone please let me know how can I build paraview with the VisIT bridge?


1 Like

Hi @sherrifbro

No need, you can just download the binary release from


Thank you! It worked.

Initially, it threw an error for missing boost libraries. After I installed them via sudo apt-get install libboost-dev, it worked like a charm.

Thanks Mathieu! I tried that before my building attempts. Simply launching it out of the extracted directory was throwing me an error: “qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.”
My guess was that it couldn’t find my Qt directories, so I thought if I build it manually I should be able to specify where those directories are (which turned out to be true). I wonder if something like add to path would fix that error with the downloaded version.

1 Like

Oh, Thanks a ton! Now I have my downloaded version working as well.
This was much easier than building by myself.