BUILD_TESTING no longer an option?


(Ethan Stam) #1

I am building paraview master branch commit 77afed7ca10ebd83a1816d0024d5f121e3d4aef0 and I’m not seeing the option BUILD_TESTING anymore. I tried setting the options PARAVIEW_BUILD_TESTING and PARAVIEW_BUILD_VTK_TESTING on, but ExternalData doesn’t build.

How do I build testing with ExternalData?


(Mathieu Westphal (Kitware)) #2

The following works on master and generates ExternalData :
PARAVIEW_BUILD_TESTING="WANT"


(Walter Alan Scott) #3

WANT? That is NOT intuitive. Why not YES or NO?


(Mathieu Westphal (Kitware)) #4

@ben.boeckel


(Ethan Stam) #5

I tried ON and WANT for PARAVIEW_BUILD_TESTING.

Neither generated ExternalData. Are there any other options I should be enabling?


(Ben Boeckel) #6

@wascott ON means “force testing to be on” which can conflict with settings like MPI being off. WANT says “enable testing and their dependencies, but skip if some required module is disabled”. As for why the tests aren’t showing up, that’s interesting. The buildbots (and I at least) are using it just fine. Is there a ParaViewData target generated?


(Ethan Stam) #7

It actually did generate. I just thought it wasn’t, because my ctest IO tests were failing. Ctest is looking for the VTK data in build_root/VTK/ExternalData/Testing/Data but it is generated in build_root/ExternalData/VTK/Testing/Data.


(Ben Boeckel) #8

I just fixed this today :slight_smile: . https://gitlab.kitware.com/paraview/paraview/merge_requests/3125


(Ethan Stam) #9

Oh cool! I’ll pull the master and try that. Thanks Ben