Building ParaView on ChromeOS with LinuxBeta

I’m using ChromeOS with LinuxBeta:

CMake is failing to find TBB, what can I do ?

A few suggestions:

  1. Do not post image of errors, but the text of the error
  2. Ask help for a specific issue, not a bunch of them
  3. Give info about your setup (Chromeboox + linuxBeta ?)

Since your setup is very specific, avoid using special option in your cmake line, just run the following command:

cd paraview_build
rm -rf ./*
cmake ../paraview

Okay! Thank you for the suggestions.
The thing is I downloaded linuxBeta today and am using the terminal for the first time so I am not sure which line is the error, but I’ll try my best.
So for each specific question, is it better if I set a new issue (not in comments)?

I have edited your question to help you already :).

You current error is the missing TBB, see my post above.

Thank you! The problem here got solved and now this appears.

Could not find a configuration file for package “Qt5” that is compatible
with requested version “5.12”.

but there seems to be many solutions on the internet so I’ll try those first.

Thank you so much for helping so much:)))))

You need to install Qt 5.12

apt install qt5 ?

Okay i tried that but it said
unable to locate qt5
so i tried
sudo apt install qt5-default
but it gives 0updates
qt5-default is already the newest version (5.11.3+dfsg1-1+deb10u4).

LinuxBeta does not provide Qt 5.12 I’m afraid and this is the minimum version supported by ParaView 5.9.0: ParaView 5.9 and minimum/recommended QT version - #3 by Dave_DeMarle

You could try building ParaView 5.8.1 or install a more revent Qt version on your system using the one provided by Qt company.

Okay. I’ll try that. Thank you so much!!!