Building ParaView with ospray issue


I have been a ParaView user for about a decade now. I develop some in-house plugins for ParaView to provide readers and filters specific to simulations we run. Consequently, I often like to build a standalone ParaView (not superbuild) during the development stage, since it allows me to build plugins externally decoupled from the ParaView build pipeline. However, when I do this, nothing renders and no errors appear with ray tracing enabled.

ParaView source for 5.11.0
OSPRay 2.10.0
OpenVKL 1.3.1
TBB OneAPI 2021.7.1
Embree 3.13.5
Visual Studio 2022
Windows 11

What I tried:
All of the DLLs I would expect for ospray (i.e. embree, openvkl, tbb) are loading correctly. I added debug breakpoint in the vtkOSPRayRendererNode.cxx vtkOSPRayRenderer::Render method, and it appears the Color and Normal buffers are all 0’s. I am unsure if this is expected when objects should be rendered. I did not have the denoiser enabled in the build, though I can try that if you think it might give me a lead.

Have you seen this issue before? Any suggestions would be greatly appreciated.

Keith Ballard

The superbuild for ParaView v5.11 currently uses ospray v2.7.1.
You are perhaps being too ambitious to go with ospray v2.10. I have had myself troubles trying v2.10 (crashes) and I reverted our builds to v2.8. I recommend you downgrade ospray and try again.

OSPRay enabled ParaView build on Windows are hard to achieve without the superbuild. I’d suggest using it as a pain avoidance road.

@jfavre Ah, good to know. I will try an older version of ospray and see if that is culprit. Although, I am shocked that all osp functions return fine given the issue. Perhaps they silently error and do not fill the frame buffer? I am not knowledgeable enough on the OSPRay renderer to have a very educated guess at why the newer version would fail without errors. I will let you know next week if the older version works.

@mwestphal I definitely hear you. Unfortunately, I need a debug build for debugging custom filters/readers. RelWithDebInfo is OK, though troublesome in some cases due to optimizations. After debugging my code, I do use the superbuild typically. Ironically, I decided to put a superbuild together to see if that would work with ospray, but I received an error I have not seen: “fatal error C1083: Cannot open compiler generated file: ‘’: Invalid argument” I will open another topic for it since other may encounter the issue.

@jfavre You were right! OSPRay 2.7 worked just fine with ParaView v5.11.0. It is interesting that nothing rendered without errors being thrown. Let me know if you need someone to test something to get 2.10 working. I am too inexperienced in the osp interface to know what would cause that issue.

@mwestphal Regarding my error…it is a bit embarrassing. The path became too large. Moving the build path closer to root sorted out the issue. Rookie mistake :blush:

This is a classic Windows issue, that is why our compilation guide suggest to use C:/pv as the build folder.