Bus error

Hello. I have problems when i’m trying to run catalyst example

[MacBook-Pro:26878] *** Process received signal ***
[MacBook-Pro:26878] Signal: Bus error: 10 (10)
[MacBook-Pro:26878] Signal code: Non-existant physical address (2)
[MacBook-Pro:26878] Failing at address: 0x10c1707e3
[MacBook-Pro:26878] [ 0] [MacBook-Pro:26880] *** Process received signal ***
[MacBook-Pro:26880] Signal: Bus error: 10 (10)
[MacBook-Pro:26880] Signal code: Non-existant physical address (2)
[MacBook-Pro:26880] Failing at address: 0x1046457e3
[MacBook-Pro:26880] [ 0] [MacBook-Pro:26881] *** Process received signal ***
[MacBook-Pro:26881] Signal: Bus error: 10 (10)
[MacBook-Pro:26881] Signal code: Non-existant physical address (2)
[MacBook-Pro:26881] Failing at address: 0x109f3d7e3
[MacBook-Pro:26881] [ 0] 0   libsystem_platform.dylib            0x00007ff8071eddfd _sigtramp + 29
[MacBook-Pro:26878] [ 1] 0   ???                                 0x00007ff7b3db8b98 0x0 + 140701851159448
[MacBook-Pro:26878] [ 2] [MacBook-Pro:26879] *** Process received signal ***
[MacBook-Pro:26879] Signal: Bus error: 10 (10)
[MacBook-Pro:26879] Signal code: Non-existant physical address (2)
[MacBook-Pro:26879] Failing at address: 0x1066377e3
[MacBook-Pro:26879] [ 0] 0   libsystem_platform.dylib            0x00007ff8071eddfd _sigtramp + 29
[MacBook-Pro:26879] [ 1] 0   libsystem_platform.dylib            0x00007ff8071eddfd _sigtramp + 29
[MacBook-Pro:26880] [ 1] 0   ???                                 0x00007ff7bb8e3b98 0x0 + 140701980310424
[MacBook-Pro:26880] [ 2] 0   libsystem_platform.dylib            0x00007ff8071eddfd _sigtramp + 29
[MacBook-Pro:26881] [ 1] 0   ???                                 0x00007ff7b5febb98 0x0 + 140701887019928
[MacBook-Pro:26881] [ 2] 0   ???                                 0x00007ff7b98f1b98 0x0 + 140701946813336
[MacBook-Pro:26879] [ 2] 0   libcatalyst.3.dylib                 0x0000000106d4ba45 catalyst_load + 1125
[MacBook-Pro:26879] [ 3] 0   libcatalyst.3.dylib                 0x0000000104d59a45 catalyst_load + 1125
[MacBook-Pro:26880] [ 3] 0   libcatalyst.3.dylib                 0x000000010a651a45 catalyst_load + 1125
[MacBook-Pro:26881] [ 3] 0   libcatalyst.3.dylib                 0x000000010c884a45 catalyst_load + 1125
[MacBook-Pro:26878] [ 3] 0   libcatalyst.3.dylib                 0x000000010a65155e catalyst_initialize + 110
[MacBook-Pro:26881] [ 4] 0   libcatalyst.3.dylib                 0x000000010c88455e catalyst_initialize + 110
[MacBook-Pro:26878] [ 4] 0   libcatalyst.3.dylib                 0x0000000106d4b55e catalyst_initialize + 110
[MacBook-Pro:26879] [ 4] 0   libcatalyst.3.dylib                 0x0000000104d5955e catalyst_initialize + 110
[MacBook-Pro:26880] [ 4] 0   CxxFullExampleV2                    0x000000010c150b7d _ZN15CatalystAdaptor10InitializeEiPPc + 573
[MacBook-Pro:26878] [ 5] 0   CxxFullExampleV2                    0x0000000106617b7d _ZN15CatalystAdaptor10InitializeEiPPc + 573
[MacBook-Pro:26879] [ 5] 0   CxxFullExampleV2                    0x0000000104625b7d _ZN15CatalystAdaptor10InitializeEiPPc + 573
[MacBook-Pro:26880] [ 5] 0   CxxFullExampleV2                    0x0000000109f1db7d _ZN15CatalystAdaptor10InitializeEiPPc + 573
[MacBook-Pro:26881] [ 5] 0   CxxFullExampleV2                    0x000000010c1528d9 main + 185
[MacBook-Pro:26878] [ 6] 0   CxxFullExampleV2                    0x00000001066198d9 main + 185
[MacBook-Pro:26879] [ 6] 0   CxxFullExampleV2                    0x00000001046278d9 main + 185
[MacBook-Pro:26880] [ 6] 0   CxxFullExampleV2                    0x0000000109f1f8d9 main + 185
[MacBook-Pro:26881] [ 6] 0   dyld                                0x0000000116d0051e start + 462
[MacBook-Pro:26878] *** End of error message ***
0   dyld                                0x000000010cfe851e start + 462
[MacBook-Pro:26879] *** End of error message ***
0   dyld                                0x000000010b3c451e start + 462
[MacBook-Pro:26880] *** End of error message ***
0   dyld                                0x000000010f53151e start + 462
[MacBook-Pro:26881] *** End of error message ***
--------------------------------------------------------------------------
mpirun noticed that process rank 3 with PID 0 on node MacBook-Pro exited on signal 10 (Bus error: 10).
--------------------------------------------------------------------------

As far as I understand, the problem occurs when executing the CatalystAdaptor::Execute(timestamp, time, grid, attributes). It doesn’t matter if I run on one processor or several - the problem still remains. Could you tell me how this can be solved? Thanks

I’m using paraview v 5.10.1, example is https://gitlab.kitware.com/paraview/paraview/-/tree/v5.10.1/Examples/Catalyst2/CxxFullExample