cannot compile iparaview-kernel

I have PV5.10.0 compiled from source, with Qt for my laptop. I cannot configure iparaview-kernel:

CMake Error at /local/apps/ParaView/5.10/lib/cmake/paraview-5.10/paraview-config.cmake:163 (list):
list sub-command REMOVE_ITEM requires two or more arguments.
Call Stack (most recent call first):
CMakeLists.txt:17 (find_package)

This error is not limited to iparaview-kernel. I have the same error attempting to compile any plugin, such as for example:

cmake version 3.18.4

@timothee.chabat @Charles_Gueunet

Hello @jfavre ,

would it be possible for you to try with CMake 3.21 ? I already saw this issue and this version of cmake solved it then.
Also, please ensure you are using the latest master of the iparaview-kernel as we added some fix few days ago :slight_smile:

This error seems to appear when building any plugin against an install folder of ParaView while using CMake < 3.21 (as far as I’ve tested). Imo this is a bug in ParaView and this should be adressed. I will open an issue and try to pindown the exact CMake version that breaks compatibility.

indeed, I installed cmake via pip and got v3.22.2.
I can configure but it fails later on on:
[ 71%] Building CXX object PVQtJupyterPlugin/CMakeFiles/PVQtJupyterPlugin.dir/pqJupyterTraceReaction.cxx.o
In file included from /local/apps/ParaView/5.10/include/paraview-5.10/pqPythonScriptEditor.h:38,
from /home/jfavre/Projects/ParaView/iparaview-kernel/PVQtJupyterPlugin/pqJupyterTraceReaction.cxx:9:
/local/apps/ParaView/5.10/include/paraview-5.10/pqPythonEditorActions.h:36:10: fatal error: pqPythonUtils.h: No such file or directory
36 | #include “pqPythonUtils.h”
| ^~~~~~~~~~~~~~~~~
compilation terminated.

Already fixed in master. I cant find the MR but @ben.boeckel knows.

found it:

@mwestphal oh good to know

@jfavre yes sadly this plugin cannot compile against vanilla 5.10 . See the iparaview-kernel README and the Patches/ folder to have the necessary patches.

I saw the README and was confused because it said if there is a version number, that means this patch is no longer needed. I see ParaView_MR_5387.patch and ParaView_MR_5446.patch and thought these numbers were versions. Sorry about that.

I applied the patch, rebuilt, and I can now compile to the end.
I have tested jupyter notebook and it works as advertized. Thanks for the prompt help.

Are these two patches scheduled for v5.10.1?

Indeed it can be a bit confusing, I will rename them. ParaView_MR_5446.patch should be backported to 5.10.1, but it’s still unsure for the other one. I’ll post a message here and update the name accordingly when I know more.

@jfavre FYI I’ve renamed the patches, only ParaView_MR_5446.patch will be backported to 5.10.1, the other one will have to wait for 5.11.0.