Cannot connect to Catalyst Live visualization on Mac OS X


I am trying to get a simple live visualization demo to run on Mac OS X 10.11. It’s the CxxNonOverlappingAMRExample. I am using ParaView v5.5.2. By the way, the example runs fine on my Linux machine.

The steps to reproduce the issue:

  1. In the CxxNonOverlappingAMRExample there is a Python pipeline, where I set the EnableLiveVisualization option to true.
  2. Build the example
  3. Open ParaView and connect to Catalyst on port 22222 (same as in the Python pipeline)
  4. Execute the example as such: ./CxxNonOverlappingAMRExample ../SampleScripts/

What I get in return is the following error message:

ERROR: In /Users/senui/paraview/VTK/Common/System/vtkSocket.cxx, line 481
vtkClientSocket (0x7f988f3a6020): Socket error in call to connect. Permission denied.

ERROR: In /Users/senui/paraview/VTK/Common/System/vtkClientSocket.cxx, line 53
vtkClientSocket (0x7f988f3a6020): Failed to connect to server Senui-Mac.local:22223

ERROR: In  /Users/senui/paraview/VTK/Parallel/Core/vtkSocketCommunicator.cxx, line 713
vtkSocketCommunicator (0x7f988bea9110): Can not connect to Senui-Mac.local on port 22223

Abort trap: 6

Even though it says its trying to connect to port 22223, I am absolutely sure I have it to 22222 in both ParaView and the Python pipeline. Again, no problems on Linux (following the exact same procedure). A colleague of mine faced the same issue a while ago (also on OS X).

Any suggestions on how to fix / debug this?


1 Like

Thoughts @Andy_Bauer ?

@cory.quammen I had created a gitlab issue before:

At the end of the discussion @Andy_Bauer said he does not have a Mac and asked if I could post it in the mailing list so that someone else could take a look at it.

Any update on this?

I saw in your GitLab issue that you could not connect that Mac client to your server. The reason, as indicated by the error message

ERROR: In /Users/ahmad/ParaView-v5.4.1/ParaViewCore/ClientServerCore/Core/vtkTCPNetworkAccessManager.cxx, line 413
vtkTCPNetworkAccessManager (0x7f97ca5003e0): 
Connection failed during handshake. This can happen for the following reasons:
 1. Connection dropped during the handshake.
 2. vtkSocketCommunicator::GetVersion() returns different values on the
    two connecting processes (Current value: 100).
 3. ParaView handshake strings are different on the two connecting
    processes (Current value: paraview.5.4.renderingbackend.opengl2).

is that your client and server versions are mismatched. Please ensure that you have the same version for both the client and the server. If you have built ParaView, ensure that both the client and server have the same rendering backend (CMake option VTK_RENDERING_BACKEND:STRING=OpenGL2). Once you have successfully connected a Mac client to your server, hopefully the Catalyst example should work.

Thanks for your reply. I tried again to connect the ParaView client with the server (both built with the exact same CMake options). I was able to connect pvserver with the client. I got the “Client connected.” message on the server.

But still when I try to run the Catalyst example, it gives the message like in my opening post. I tried changing port numbers (on both client and server), but same problem.

For the sake of future internet searchers, there’s an explanation and workaround here: