cannot render when using the osmesa build

Hello everyone,

I use a set of scripts to export a standard set of pictures for specific simulation types. The scripts run just fine and produce the expected pictures, which is as intended (so great job on that to devs!)

The number of simulations has recently increased, so I tought I would try to include the post-processing inside the job running on our cluster by using the osmesa build available from the downloads page.

Unfortunately, that did not give the expected result. It produces a SIGSEGV when the script creates a new render view, with the message

[pvbatch         ]vtkOpenGLRenderWindow.c:458    ERR| vtkOSOpenGLRenderWindow (0x16807780): GLEW could not be initialized: Missing GL version

I tried on a compute node (so no x server I guess), but also on another node with a x server present, where the regular paraview version works.

Not sure what I am missing. I thought the osmesa build was supposed to be made for such cases ?

Can anyone give a clue to what I am doing wrong ?


Is there a subtility about the osmesa build that I am missing that could help fix this issue ?


I just tried ParaView 5.9.1 osmesa binary release without X server and it is working great.

Please share how you run it ?

I am not really doing anything special:

  1. Download osmesa build.
  2. Unzip on the cluster I use.
  3. run the pvbatch binary from the bin folder with my python script.

I do not know if it is of interest, but here is the the output of ldd:

ldd /cm/shared/apps/paraview/5.9.0-osmesa/bin/pvbatch (0x0000155555551000)
	/usr/NX/scripts/vgl/ (0x0000155555129000)
	/usr/NX/scripts/vgl/ (0x0000155554db3000) => /cm/shared/apps/paraview/5.9.0-osmesa/bin/../lib/ (0x0000155554b58000) => /lib64/ (0x0000155554954000) => /lib64/ (0x00001555545bf000) => /lib64/ (0x000015555423d000) => /lib64/ (0x0000155554025000) => /lib64/ (0x0000155553c63000) => /lib64/ (0x00001555539d0000) => /lib64/ (0x000015555368c000) => /lib64/ (0x0000155553479000) => /lib64/ (0x0000155553259000)
	/lib64/ (0x000015555532b000) => /lib64/ (0x0000155553027000) => /lib64/ (0x0000155552d6b000) => /lib64/ (0x0000155552b42000) => /lib64/ (0x000015555293e000)

Definitely not the right binary:

[glow@arch ~/work/paraview/others/ParaView-5.9.1-osmesa-MPI-Linux-Python3.8-64bit/bin]$ ldd pvbatch (0x00007fff0f927000) => /home/glow/work/paraview/others/ParaView-5.9.1-osmesa-MPI-Linux-Python3.8-64bit/bin/./../lib/ (0x00007f343ba0b000) => /usr/lib/ (0x00007f343b9e5000) => /usr/lib/ (0x00007f343b7cf000) => /usr/lib/ (0x00007f343b68b000) => /usr/lib/ (0x00007f343b670000) => /usr/lib/ (0x00007f343b4a4000)
        /lib64/ => /usr/lib64/ (0x00007f343bc68000)

[glow@arch ~/work/paraview/others/ParaView-5.9.0-osmesa-MPI-Linux-Python3.8-64bit/bin]$ ldd pvbatch (0x00007ffdc373a000) => /home/glow/work/paraview/others/ParaView-5.9.0-osmesa-MPI-Linux-Python3.8-64bit/bin/./../lib/ (0x00007f6b163f3000) => /usr/lib/ (0x00007f6b163cd000) => /usr/lib/ (0x00007f6b161b7000) => /usr/lib/ (0x00007f6b16073000) => /usr/lib/ (0x00007f6b16058000) => /usr/lib/ (0x00007f6b15e8c000)
        /lib64/ => /usr/lib64/ (0x00007f6b16650000)

Did you download it from the headless section here:

That’s supposed to be the case.

I just checked the md5sum so the archive I used:

md5sum ParaView-5.9.0-osmesa-MPI-Linux-Python3.8-64bit.tar.gz 
6a9cb14c0ef33f21468e85fb5141052b  ParaView-5.9.0-osmesa-MPI-Linux-Python3.8-64bit.tar.gz

that’s the same as the one available from the downloads:

md5sum ParaView-5.9.0-osmesa-MPI-Linux-Python3.8-64bit.tar.gz 
6a9cb14c0ef33f21468e85fb5141052b  ParaView-5.9.0-osmesa-MPI-Linux-Python3.8-64bit.tar.gz

The output I copied came from a machine with an xserver installed. could it be that that’s the cause of the different ldd output ?

Can you try downloading and extracting again ?

I’ve also have a Xorg server running when running ldd.

I’ve re-downloaded 5.9.0 and 5.9.1. Checked the md5sums, extracted all, but the ldd still shows the same libraries. I do not know why.

the md5sums of pvbatch itself:

9049f5f9582801cf59d613ecc1239605  pvbatch


a04ddd2e879db2645e625d944db1ef33  pvbatch

I have the same md5sum, checked on another computer and I have the same ldd output. No idea what is happening. Please try on anothere computer.

I tried again a couple things this morning to get this to work and succeeded!

VirtualGL is used on our cluster to accelerate 3D rendering.
Two librairies


are explicitely given declared in the LD_PRELOAD variables.
by using


before starting pvbatch, that fixed the ldd output, and the binary too!
so fixed!

Right, I should have though of it.