Can't start paraview in Fedora 37


I am having trouble starting paraview in Fedora 37. I have tried installing from the repo and downloading the binaries. This gives me two separate errors. In the installation from the fedora repo:

paraview: symbol lookup error: /usr/bin/…/lib64/paraview/ undefined symbol: _ZN20vtkDIYGhostUtilities29InflateBoundingBoxIfNecessaryEP10vtkDataSetR14vtkBoundingBox

And from the bindary:

qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: xcb.

error: exception occurred: Subprocess aborted

I have gone down the rabbit hole on xcb and Qt for that second error, but did not find a solution. My issue seems to be the same as this one:

However, I don’t understand what was done in that case to actually solve the issue. If anyone has any ideas that would be great.


Hi bloodpressure. Great name, by the way. My guess is exactly what the SOLVED paragraph states. I believe ParaView doesn’t need a path variable, so kill yours. As I don’t know what shell you are using, I will assume it is bash.
export PATH=

If that doesn’t work, try something like
export PAHT=/

Well, thanks for the response. I wish I could say I thought of that pun when I chose the name, but in reality it was just the thing at the top of my mind at the time…

So based on your comment, I think I have identified the problem. You are correct that I am using bash. I commented out all the lines in my .bashrc that were non-standard, which were for Julia, FDS (fire dynamics simulator), VisIt, and openfoam. After logging back in, both versions of paraview were working again! It turned out that something in the FDS scripts was breaking things:

#source ~/FDS/FDS6/bin/ 
#source ~/FDS/FDS6/bin/

This was surprising to me, because FDS doesn’t use paraview, and I didn’t have any mention of paraview anywhere in my .bashrc. Those two .sh files make multiple export commands, and none of them involve paraview as far as I can tell.

I did try

export PATH=“/usr/bin/paraview:$PATH”

but no luck.

So for now, I will just not expect paraview and FDS to coexist together peacefully and only use them in separate sessions. Solution found, the mystery continues…


Glad it worked.

PATH (and LD_LIBRARY_PATH) does more than just say “Go find ParaView somewhere here”. It can also say “go search here for libraries or system stuff”. And, that’s the danger of EVER putting commands like you have in your bashrc. You don’t know what those scripts are running. My guess is they are messing with PATH, or LD_LIBRARY_PATH, or somesuch, and you were picking up a non standard library. Anyway, glad you figured it out.

Yes, that is interesting - these sorts of source commands in the .bashrc seem to be common for installing packages like openFoam and FDS, but I never really appreciated how different that is from simply adding the binaries directories for things like julia and paraview. Guess that’s why I am not a developer!

Thanks again-