Clipping by scalar incorrect for super-build


I have compiled paraview superbuild 5.10 and 5.11 (5.12 failed on download - separate problem) but when reading OpenFoam VTK files and clipping the data by the U_Z velocity, I get the following image:

If I clip the same data with the system paraview (5.10), I get the following correct result:

This suggests there is something wrong with how I have compiled paraview. The reason for compiling paraview is to have some additional python modules as well as rendering. I followed the instructions as per here. The cmake command I am using is as follows:

cmake -DPARAVIEW_BUILD_EDITION=CANONICAL -DPARAVIEW_USE_PYTHON:BOOL=ON -DENABLE_python3=ON -DPython3_EXECUTABLE:FILEPATH=path/to/env/bin/python3.10 -DENABLE_qt5=ON -DENABLE_ospray=ON -DENABLE_boost=ON -DENABLE_cxx11=ON -DENABLE_eigen=ON -DENABLE_ffmpeg=ON -DENABLE_fortran=ON -DENABLE_lapack=ON -DENABLE_las=ON -DENABLE_libxml2=ON -DENABLE_nlohmannjson=ON -DENABLE_paraview=ON -DENABLE_tiff=ON -DPARAVIEW_USE_PYTHON=ON -DPython3_EXECUTABLE=ON -DUSE_SYSTEM_png=ON -DUSE_SYSTEM_python3=ON -DUSE_SYSTEM_qt5=ON  /path/to/paraview/superbuild/folder/paraview-superbuild/

I am compiling on Ubuntu 22.04.

I do have the python modules that I required, rendering is available and paraview and pvpython run, but they produce the unexpected results as shown in the images.

Does anyone know what I have done wrong or any suggestions as to how to troubleshoot this further.


Can you test the binary release as well ?

Please share your data.

Hi Mathieu,

Thank you for getting back to me so fast.

I have tested the binary release from here. I have tested with both 5.10 and 5.11. The 5.10 binary produced the smooth clip and the 5.11 produced the jagged clip as before.

To reproduce what I observe: added a clip to the data → clipped by scalar Uz (value = 0.2, click invert) → apply.

I have uploaded the data here. There are two files:
internal.tar.gz is the original file I was using.
I also extracted the Uz scalar and saved the data from within ParaView to “extractedData.vtm” which created the *.vtm files and the folders with the same name. This was just to try make your life easier by not having to download the whole data set.

Thank you again for your help

I reproduce with 5.11.1 but it seems to have been fixed in the meantime, you can test the nightly here:

If you want to build it yourself, set this cmake option in the superbuild:



Thank you Mathieu.

I will stick to 5.10 for now and wait for a super-build with the newer version.

Since the bug seems to have been resolved already I consider this issue resolved.

Your help has been greatly appreciated.



Just to confirm, I tried the nightly build (5.11.1) using the


flag and it showed that the clipping issue had been resolved.