Compatbility with older Linux OS versions


(James) #1

Hi - Is there a compatibility matrix for 5.5.2 & which Operating Systems are supported?

I’m running sles 11 patch 4 which is quite old and getting some QT lib errors:

symbol lookup error: /lustre/apps/ParaView/ParaView-5.5.2-Qt5-MPI-Linux-64bit/lib/libQt5XcbQpa.so.5: undefined symbol: XIQueryVersion


(Mathieu Westphal (Kitware)) #2

I’m afraid sles 11 SP4 is untested by our buildslaves. We actually do not have any SLES nor Open Suse buildbot.

Your issue may be related to this one : https://bugreports.qt.io/browse/QTBUG-38050
You may want to try with older release of ParaView, or by building ParaView yourself.


(James) #3

Hi Matteiu. Thanks for the reply, the version of SLES we are running is 11, patch 4, not SLES 4 as you stated. Do you know what version would run on this OS if any? Thanks in advance for your suggestions…


(Mathieu Westphal (Kitware)) #4

It was only a typo, i’ve corrected it.

You may want to try with older release of ParaView, or by building ParaView yourself.