Connection failed during handshake

I am running pvserver on remote linux machine (paraview v5.8.0)
but when I try to connect on the windows PC with same version of paraview
Connection failed during handshake

I can get 3.98.1 and 4.1.0 to connect,
but then they crash out when I try to load the temp.foam file.

Waiting for client...
Connection URL: cs://giles-calc-machine:11111
Accepting connection(s): giles-calc-machine:11111
Client connected.
ERROR: In /home/utkarsh/Dashboards/MyTests/NightlyMaster/ParaViewSuperbuild-Release/paraview/src/paraview/VTK/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx, line 530
vtkXOpenGLRenderWindow (0x17593f0): bad X server connection. DISPLAY=ERROR: In /home/utkarsh/Dashboards/MyTests/NightlyMaster/ParaViewSuperbuild-Release/paraview/src/paraview/VTK/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx, line 322
vtkXOpenGLRenderWindow (0x17593f0): bad X server connection. DISPLAY=Segmentation fault (core dumped)

Looks like you have a X configuration issue. Did you set the DISPLAY var on your remote machine ? Is that a Xorg server running ?

Thanks Matt,

no, I have not set up any DISPLAY yet.

I’m using exactly the same procedure that I use on my laptop (which works fine in pv3 and pv4), but for some reason it doesnt work from my workstation.

Normally I can only connect using pv3 or pv4, but in this case it does connect,

and the pv window comes up, but as soon as I try to load the .foam file it crashes out.

Ideally I would like to be using pv5.8.0, but the handshake doesnt work for that one.

(on any of my machines).

I will try your suggestion about the DISPLAY seeting - what do you use

export DISPLAY=localhost:0.0 (?)

DISPLAY depends on your machine, you can find it using ps:

[glow@frollo ~]$ ps -ef  | grep Xorg
glow        1039    1038  2 11:16 tty1     00:11:52 /usr/lib/Xorg -nolisten tcp :0 vt1 -keeptty -auth /tmp/serverauth.ToFiCxwsH7
glow      171907  170142  0 17:57 pts/2    00:00:00 grep Xorg

In my case, I should use



sorry I dont know what the grep command is telling me…

ubuntu@giles-calc-machine:~/working/bldg-simpleFoam-fstream-cylinder$ ps -ef  | grep Xorg
ubuntu    326643  325813  0 10:05 pts/0    00:00:00 grep --color=auto Xorg

I just tried setting display and I still get the same coredump, when loading a file.

No protocol specified
ERROR: In /home/utkarsh/Dashboards/MyTests/NightlyMaster/ParaViewSuperbuild-Release/paraview/src/paraview/VTK/Rendering/OpenGL/vtkXOpenGLRenderWindow.cxx, line 322
vtkXOpenGLRenderWindow (0x14543f0): bad X server connection. DISPLAY=:0

Segmentation fault (core dumped)

Simple, you have no Xorg running on your server. You cant use the OpenGL version of binary without a Xorg server running.

what I mean is that is works fine when Im connecting via windows laptop to linux machine…

but when connecting from my windows workstation to linux machine, its not working.

so Im assuming something not right with my Windows workstation ?

I’m confused, please state exactly what you are doing, what is working and what is not.

ok. I connect windows laptop to Linux (ubuntu) workstation.
then start pvserver in ubuntu. then start paraview on windows laptop.
then I can connect (in paraview), and open files, and it works fine. all good.

But the doing same from my windows workstation doesnt work,
although I can connect (in paraview), and see the files in Linux workstation,
but as soon as try to open one of them, paraview crashes out with that error message, and coredump.

I’d start by deleting your local paraview settings.

sorry - Im not sure what you mean by that…?

  • Edit → Settings → Restore Defaults

  • restart paraview

that doesnt make much difference. BUT I have just discovered that its only the larger cases that it crashes out on, so maybe its more of a graphics RAM issue. I dont know how much RAM is required for rendering larger meshes, although this case Im using now is only 200k cells and that is crashing out.

I think your were right in the first place - it seems to be a lack of xserver thats the problem.
so we need to install the osmesa version in 5.11.0 then?

egl or osmesa version should do the trick.