Connectivity Crashing on Time Update in pvbatch without GUI

I am trying to loop over the connectivity filter at different time steps to perform calculations for each region using pvbatch on a cluster (RHELS 7.8). The only way I can get the data to try to update with a changed timestep is via a Render command or animationScene. Whenever I do this I get an error (below) that appears to be related to the connectivity filter. The initial time step does have an empty connectivity filter but even when I force the next time step to be populated this error comes up. I do NOT have this problem when run through the GUI. Have tried Paraview 5.8.0, 5.8.1, 5.9.0 RC2,3 all without success.
Any ideas? Thank you
from paraview.simple import *
# get active view
renderView1 = GetActiveViewOrCreate(‘RenderView’)
layout1 = GetLayout()
spcth = SpyPlotReader(FileName=p2f+’/spcth.0’)
spcth.CellArrays = [ ‘Temperature (eV)’,‘Volume Fraction - 2’,‘Specific Energy (erg/g) - 2’,‘Specific Energy (erg/g) - 4’,‘X velocity (cm/s)’, ‘Y velocity (cm/s)’]

animationScene1 = GetAnimationScene()

timeKeeper1 = GetTimeKeeper()
# create a new 'Calculator'
calculator_tempk = Calculator(Input=spcth)
calculator_tempk.AttributeType = 'Cell Data'
calculator_tempk.ResultArrayName = 'Temperature (K)'
calculator_tempk.Function = 'Temperature (eV)*11604.52500617'
# create a new 'Threshold' For Hotspots
threshold_hotspot = Threshold(Input=calculator_tempk)
threshold_hotspot.Scalars = ['CELLS', 'Temperature (K)']
threshold_hotspot.ThresholdRange = [500, 10000000.0]
# Connectivity of Pores
connectivity_hs = Connectivity(Input=threshold_hotspot)
t_step = timeKeeper1.TimestepValues[::10] # Array of time_steps

Error Thrown:
^[[0m^[[31m( 6.042s) [pvbatch.3 ]vtkPConnectivityFilter.:504 ERR| vtkPConnectivityFilter (0x40f8930): No points in data set^[[0m
^[[0m^[[31m( 6.0 44s) [pvbatch.11 ] vtkExecutive.cxx:753 ERR| vtkPVCompositeDataPipeline (0x2ec1ff0): Algorithm vtkPConnectivityFilter(0x2ecfd50) returned failure for request: vtkInformation (0x2f696e0)
Debug: Off Modified Time: 181742 Reference Count: 1 Registered Events: (none) Request: REQUEST_DATA ALGORITHM_AFTER_FORWARD: 1 FORWARD_DIRECTION: 0 FROM_OUTPUT_PORT: 0

Note: I have tried using connectivity_hs.UpdatePipeline(time=t) along with updating each filter explicitly. The error is thrown whenever I try to update connectivity_hs.