I have .pvd files exported from MFIX, but I cannot access the contour filter. It appears locked. It is the same for the .SPX files exported. I am unsure whether I am missing something in Paraview, or the files exported don’t allow such filtering. (Note that contours work well with the test you provide: disk_out_ref.ex2)
Any help will be appreciated.

It would be helpful if you could post your data. I cannot say for sure what is wrong without more information about it. But I suspect the problem is that your data does not have any scalar point data. The contour filter needs some field defined over your data (such as temperature or pressure) to extract the surface where that is equal to some value. Generally, for the contour to work, the filter needs scalar values (as opposed to vector values), and those values need to be attached to point data so they can be interpolated.

My guess is that your data does not have any field data or that you have field data that is either attached to cells or is in a vector. If the latter is the case, the easiest way to solve your problem is to go to Settings (Edit -> Settings… on Windows/Linux, ParaView -> Preferences… on Mac) and turn on the “Auto Convert Properties” option.

Thanks a lot for the quick answer and you are right, by turning on the Auto convert properties, it allows me to plot the contours now.

Is it actually possible to plot the contours of not only a single value, but encompassing everything below that value?
say it is an volcanic explosion, and I want to contour the whole ash-cloud, I would say, contour everything where
solid density > 0, how can this be achieved?
Thanks for your help

This short answer is to try the Threshold filter.

yes, but that shows say everycell, not render a nice smooth surface like the isosurface does.

I spoke too fast earlier. The contours are enable, but it has some issues showing them. For instance, when selecting a property to plot, it does not show the range of the property, and when plotting, nothing shows up.

Please see the .pvd if that helps you see it too.


An alternative to “Auto Convert Properties”, in case you want to manually do this step, is to run the Filters/ Alphabetical/ Cell Data to Point Data filter.

If you don’t like Ken’s suggestion of Threshold, because it is jaged, use the Clip/ Clip Type Scalar filter. Note that if your data is cells, it will be blocky as with Threshold. But, if it is points (or you have run Cell to Point filter above), it should be a 3d filled smooth surface.

Thanks Walter,
using the manual cell data to point data, the contours worked nicely now.

I did not get what you meant by Clip/ Clip Type Scalar filter. What filter is that specifically?

Filters/ Common/ Clip. (This is also on the toolbar just above the Pipeline Browser.)
Clip Type == Scalar.
Chose your variable, as you would with a contour.
Chose your Value, as you would with a contour.

Tutorials are found off of the Help menu. Try this one:, then Sources and Filters. Clip by Scalar is in there.

Done, it is real cool. Thanks for the quick help