Corrupt kd tree error in XDMF

Hi all,

I filed an issue for this, but figured I’d reach out here and see if anyone else has run into this issue…
When I’m running version 5.6.0 in client server mode with the server side compiled with osmesa off-screen rendering (v18.2.5), occasionally I’m getting the following error:

ERROR: In /home/shelf1/compile/visualization/src/paraview/5.6.0_gui/VTK/Common/DataModel/vtkKdTree.cxx, line 1956
vtkKdTree (0x573d5fa0): vtkKdTree::BuildMapForDuplicatePoints corrupt k-d tree

I did some searching online, and this may be related to an issue in the discussions here:

Has anybody else run into this problem? It seems to be quite random and changing the proc number can solve it, and running in serial is guaranteed to.

Link to the issue I submitted:

I hope this isn’t considered necromancing, but I just wanted to give a heads-up that I’m running into the same error.
I’m using vtm/vtu datasets, and the error occurs when I try to distribute the mesh between processes with the D3 filter. I see the same behaviour you mentioned, that changing the number of procs solves it, and also if I use prepartioned data in the pvtu format it works fine with any number of procs…

Has there been any update on this issue so far? I’m mostly using ParaView.5.6.2, but I also tried the same case with 5.7 and 5.8, and the error occurs for all of them.

Can you share your dataset and steps to reproduce the issue?

Steps to reproduce are:

  1. Import dataset
  2. Distribute dataset with D3 filter
  3. Update pipeline

For me the error appears if I use at least 11 processes. Concerning the dataset: I can share it, but it’s quite large (around 3.5GB). If you could give me an email address I could send you a link to download it.

Could you try with the new Redistribute Dataset filter available in ParaView 5.8 ?

I tried the new Redistribute Dataset filter. However, when I use it in parallel, paraview seems to hang. At first, I see a lot of activity (high process load), but after a while the load on the pvserver processes drops sharply, and paraview is stuck on “RedistributeDatSetFilter (62%)”. If I use the “Split Cells” setting, instead of “Assign cells uniquely”, then it is stuck on “RedistributeDatSetFilter (81%)”. This behaviour also seems to be independent of the number of process used.

I used it directly on the imported dataset. Do I need to use any other filters before that?

There is no reason for it not to work, nor there is with D3 anyway.

Ideally, if you could reproduce the issues with a smaller dataset and with a smaller number of cores, we could open an issue.

If not, it will require some investigation.

Ok, I’ll try and see if I can reproduce it with a smaller dataset. The “problem” is, I tried it on some other cases of mine, and everything worked without issues, so it might be a problem with the mesh topology of my current case…