Creating an animation

hello I am new to paraview and am trying to produce an animation from a group. When I select the group and set the required properties in the cell array status shown below and hit run in the top nothing happens. Can anyone tell me where am I going wrong and how can I get it working?
I am using PeleLM and it generates binary files as per my knowledge. I have group of plot files at different time steps. How can make an animation out of it?
Thanks a lot

Welcome to ParaView, @R_Surya_Narayan!

It looks like you are selecting all directories individually. When you do that, each timestep is opened as a separate dataset.

Instead, click on the entry plt_… and click OK. That should load your dataset as a time series.

Let us know if that doesn’t work.

thank you so much for your reply. I have selected the entire directory and have tried to hit run. But that doesn’t work. Maybe I have to do something with the animations tab to make it work!?

@cory.quammen Is it possible to manually create an animation from individual plots from the pipeline browser? I have painfully taken 20 of the 98 datasets and set the cell array status to ‘x-velocity’ in the dropdown at the top and when I vizualize each contour one by one, there seems to be a change in the plot. Have attached the image below:

Oh no, you don’t want to have to do that :slight_smile:

Make sure in the file open dialog that you are selecting just one item in the file browser, the plt_.. entry. Don’t select individual subdirectories.

@cory.quammen do you mean this procedure?

I have tried this. Once opened in the pipeline browser, I select the group and then apply the required property in the cell-array status (in my case x-velocity) and then hit the “run animation” in the top. It doesn’t change (and there is no animation!).

I just see the first plot of the plt.. group across the entire time domain. Maybe I am doing it wrong somewhere?

Yes, that’s what I mean. Thanks for trying it out, looks like there could be a bug.

Could you package just two or three of the individual timestep directories into a zip or tarball and share that so we can take a look? If the file is small enough, you should be able to attach it here, otherwise could you share it on a file sharing service?

1 Like

@cory.quammen Thank you so much for your prompt replies! Sorry for the late response from my side. I shall have to contact my guide to be able to share the files. Shall let you know soon. If I get a heads up I will put up a google drive link to the same.

@cory.quammen Please find the first few of the plot files zipped into this google drive link. Thank you so much for your support! Please let me know if you are able to download the files.

@R_Surya_Narayan Thanks for the files. I am indeed able to load them as a time series and play through them. Here’s what I did:

  • Unzip your files
  • Open ParaView
  • File -> Open… Navigate to the directory contain the time series and select only the plt.. item. Click OK.
  • Enable all Cell Arrays
  • Change the color array to “avg_pressure”
  • Change the representation to Surface with Edges
  • Now click on the animation controls to go forward and backward in time. You should see some difference in the surface coloring within each cell.

If you don’t see any change, try resetting the color map range:


1 Like

Thank you so much for these detailed steps. I shall let you know if it worked at the earliest!

I tried these steps previously too. The part on scaling was new to me and I tried that too. I still see no effect. Is it because of an outdated version of paraview? I currently have 5.9.

I used 5.9.0 to check. Are you using the “AMReX/BoxLib Grid Reader” to read in the files?

After you have loaded the sequence, click on the Information tab. Scroll down to where it lists time info. What timesteps are listed?

I see this from the sample dataset you shared:


@cory.quammen Thank you for your timely responses and sorry for replying late. I am surprised myself at what got this working finally-I installed paraview on my windows partition and tried the same with the datafile I had given you and it worked. Hence, there seems to be an error with my installation of paraview in the ubuntu partition. Therefore, the solution is pretty clear here-reinstall paraview in my ubuntu partition. Sorry to have troubled you!