Curved edges changed to straight edges when plotting stress contour using VTK file


I’m trying to plot the stress contour in a plate with a circular hole. Due to symmetry, only one quarter was simulated. A VTK file for coordinates of all nodes with the associated stress component (scalar) was generated. Then opened the VTK file in Paraview and used Delaunay 2D filter and got the result as in the attached image. As can see, the curved edge was changed to a straight edge while it should look as in the second image when I used only points to output the stress contour.

Any help to get the stress contour with the exact curved edge will be appreciated.

This is expected, the Delaunay filter will return by default the convex hull of your input dataset . You can however experiment with the Alpha parameter. From the documentation (hitting ? button ):

The value of this property controls the output of this filter. For a non-zero alpha value, only edges or triangles contained within a sphere centered at mesh vertices will be output. Otherwise, only triangles will be output.

Thanks Christos
. I actually tried playing with Alpha parameter and the best result I got is when Alpha=0.2 but still not the a prefect quarter-circle as seen in the new image. It kind of approximated by line segments.

Yeah, with this filter that’s the best you can get. To get the exact curved edge you need to save the element connectivity as part of your file. It seems that currently you only save the points ?

Sorry, I forgot to mention that I’m using a meshless numerical method (point collocation method) in the analysis and thus no elements are used in the discretization of the domain but just a cloud of points.

In this case I am not aware of any method in ParaView that can construct the curved elements on the boundary.

1 Like

You could use the Clip Screen Shot 2023-11-30 at 9.37.46 AM filter with the Clip Type set to Cylinder set to the location of your hole. (Also turn off Invert.) That should remove the triangles that Delaunay 2D extraneously adds.


Thanks Kenneth. Your solution worked like a charm. Much appreciated!