Default reader not honored when loading exodus file

OS: MacOS Sonoma (for what it is worth I was seeing this same behavior on Ventura as well)
ParaView version: 5.11.2
Obtained ParaView: From the downloads page on the ParaView website.
Do you see the problem on latest nightly build: Yes

This question is related to this post but I believe is different enough to warrant its own question. I have activated the LegacyExodusIIReader plugin and have it autoload since the default IOSS reader crashes with my .e file as highlighted in the linked post. My issue is every time I open ParaView the Open Data With... window pops up asking me to select either the IOSS Reader or Legacy Exodus II Reader even though I’ve clicked the Set reader as default button for the Legacy Exodus II Reader. I click this Set reader as default every time I open ParaView, hoping one time it will permanently stick and the Open Data With... window will cease to pop up.

I’ve gone to Preferences->Miscellaneous and under in the Default reader details I see the following:

So it appears to be properly adding the default reader to the list but it doesn’t honor it when I open *.e extensions. The line is added every time I click Set reader as default. Can someone explain to me why this is happening and how I can fix it so the Open Data With... window stops open every time I open ParaView?


I’m unable to reproduce with ParaView 5.11.1 binary release on linux. The mechanism seems to work perfectly. Please try to identify if this issue is specific to macOS.

I’ll have to reach out some of my colleagues and see if there are any linux and or Windows boxes to confirm whether it is a macOS only issue. It looks like your testing rules out the issue on Linux. I have confirmation from other macOS users in my team that they have seen this issue. I’ll have to confirm if it is only the ARM based architecture or also the older intel based macs.

@phismith Please test this with Windows, Mac and Linux. Reply back here, and talk to me on what you find. Thanks.

I can confirm that the behavior is different on Windows vs Mac. On Windows, setting a default reader opens future files with the same extension in that default reader without prompting a pop-up menu choice. On Mac, it always presents the pop-up.

Looks like a macOS specific issue then, please open it :

List the link here please. Sandia will fund it.

Default readers not honored on MacOS (#22400) · Issues · ParaView / ParaView · GitLab (

Here you go. Thanks, Alan!


I tried this out with v5.12.0-RC1 on Mac IOS Sonoma on an x86 Mac and it looks like it works fine. Please see if it works for you on the ARM machine with v5.12-RC1.



In looking into v5.12.0-RC1 I have come across something interesting. Both the v5.11.2 and v5.12.0-RC1 work if and only if I open ParaView from /Applications/ParaView-5.12.0-RC1 and go to File->Open and navigate to the .e files after selecting the LegacyExodusIIReader as default the first time. However, that’s not how I’ve typically opened files for the ~10 years or so I’ve used ParaView. I’ve always added an alias to my .bash_profile or .zshrc as follows:

alias paraview="/Applications/

so I can simply type anywhere in the terminal paraview file_name.e to open the file. Opening files this way, which is what I was doing in my testing in my original post still does not work with v5.12.0-RC1. The pop-up Open Data with... always pops up even after selecting a default. Interestingly, other defaults have always been recognized in opening ParaView this way (autoloading the Legacy plugin as it appears in the pop up window for selection, my changes to default point size, colorbar, etc.).

Any idea why opening via an alias would lead to different behavior?

@woodscn I’m going to take a guess. Please delete your configuration files, using Edit/ Reset to Default Settings. Then, please try running 5.12.0-RC1. Does that work better?

I’m on Windows and Linux; @gambka will have to test the Mac aspects.

Sounds like settings not working correctly that way?

After deleting the configuration files and trying to reset the default reader still results in the same behavior when using an alias to open the executable versus manually opening files through the ParaView gui.

It does sound like the settings are not working correctly using the alias, but what I don’t understand is the alias is simply the path to the same executable that is executed when you double click on the ParaView icon in Applications.

My use case may be too specific to warrant a fix. It is probably more prudent for me to figure out why the IOSS reader is crashing and fix the creation of my Exodus file so I can avoid the need for the legacy reader since it will be phased out of ParaView eventually.

Hi Kyle,

I just tried it with the file I am attaching and it works fine. Can you provide a file that will not work for you? Or did you get your file fixed?

cube_ssvar_mtrans.e (2.0 MB)

I was able to change the mesh creation script such that the IOSS reader no longer crashes. I still have issues with the default reader being honored if opened via a command line alias as I described previously for any and all .e files, including the one you provided. Opening manually via the GUI works as intended.

Now that I’ve corrected the root cause requiring the LegacyExodusReader in the first place I think I’m fine. I know the goal is to remove the LegacyExodusReader in the future so it may not be worth the time and effort to get it to work for the specific use case through an alias to open ParaView.

I do appreciate everyone’s help regarding this issue.