Disable interactive view window when running pvpython

Hi all,

I use pvpython to convert vtk file to image. During each processing procedure, the interactive view window (for my case is renderView1) will appear in real-time, is there any settings of renderView1() to disable the appearance of view window?

Thanks!

Just use pvbatch instead. Or pass in the --force-offscreen-rendering command line to the pvpython exectuable as so ../pvpython --force-offscreen-rendering ... [your script.py]

Hi Utkarsh, thanks for your reply! I add the argument --force-offscreen-rendering after pvpython, but I got “Got unknown argument: --force-offscreen-rendering”, and all the argument include:

--connect-id=opt        Set the ID of the server and client to make sure they match. 0 is reserved to imply none specified.

  --cslog=opt             ClientServerStream log file.

  --data=opt              Load the specified data. To specify file series replace the numeral with a '.' eg. my0.vtk, my1.vtk...myN.vtk becomes my..vtk

  --disable-registry      
  -dr                     Do not use registry when running ParaView (for testing).

  --enable-bt             Enable stack trace signal handler.

  --enable-streaming      EXPERIMENTAL: When specified, view-based streaming is enabled for certain views and representation types.

  --help                  
  /?                      Displays available command line arguments.

  --hostname=opt          Override the hostname to be used to connect to this process. By default, the hostname is determined using appropriate system calls.

  --mpi                   Initialize MPI on processes, if possible. Cannot be used with --no-mpi.

  --multi-servers         Allow client to connect to several pvserver

  --no-mpi                Don't initialize MPI on processes. Cannot be used with --mpi.

  --print-monitors        Print detected monitors and exit (Windows only).

  --server-url=opt        
  -url=opt                Set the server-url to connect with when the client starts. --server (-s) option supersedes this option, hence one should only use one of the two options.

  --state=opt             Load the specified statefile (.pvsm).

  --stereo                Tell the application to enable stereo rendering

  --stereo-type=opt       Specify the stereo type. This valid only when --stereo is specified. Possible values are "Crystal Eyes", "Red-Blue", "Interlaced", "Dresden", "Anaglyph", "Checkerboard","SplitViewportHorizontal"

  --test-plugin=opt       Specify the name of the plugin to load for testing

  --test-plugin-path=opt  Specify the path where more plugins can be found.This is typically used when testing plugins.

  --use-cuda-interop      
  -cudaiop                When specified, piston classes will use cuda interop for direct rendering

  --version               
  -V                      Give the version number and exit.

I don’t find the one to control the off-screen rendering.

I use ubuntu18.04+openfoam4.1+paraview5.0.1, so I also try --user-offscreen-rendering according to ParaView: ParaView and Offscreen Rendering, but still not work.

Do you know how to solve this problem?

5.0.1 does not support this option. You’ll have to upgrade to a newer version, alas.

Thanks for your information! My current paraview 5.0.1 is compiled installed together with openfoam 4.1 in ubuntu 18.04. Can I just upgrade it? Or I need to download the latest version paraview and reinstall it in linux?