Display of FVCOM data broken in recent nightlies

(Simon) #1

Hi all,
My apologies in advance for a not-ideal bug report. Everything below is on Windows, but I don’t have the ability to run the linux version, so I can’t tell you whether it is Windows-specific.

In 5.6.0, I can open FVCOM output files (which are netCDF, using the “VisItNetCDFFVCOM_MTSDReader” reader). There’s the known problem in 5.6.0 in Windows that it won’t read files of >2Gb, but otherwise it works, and some beautiful plots are possible.

In recent nightly builds (I’ve tested 1554 and 1598), the large file problem is fixed, but reading FVCOM files seems to be broken. I can open them happily, and see the available fields populated in the Properties pane, but no matter what I select and Apply I never see anything rendered, and the toolbars that control color maps, rendering type, etc., stay greyed out. There’s nothing relevant in the Output Messages.

Rendering is not broken for all data - the example files that ship with Paraview still display - but I can’t get anything from FVCOM to show.

Here’s a relatively small (47Mb) example file that works on 5.6.0 but not in recent nightlies:

Beyond this, please let me know if I can usefully provide any other info, or if you’d like me to file a bug report on gitlab.

Simon.

(Simon) #2

I can now offer an example data file that works in 5.6.0 but not in 1598.
It’s 47Mb, and is at https://www.dropbox.com/s/8otkg1bxwprm0me/casename_0001_modified_z.nc?dl=0

(Cory Quammen (Kitware)) #3

We recently updated the NetCDF library. Could you try the most recent nightly and report if you see the problem?

I just tried on macOS from a recent nightly and was able to load the data.

(Simon) #4

Same problem with 1703, I’m afraid. Maybe this is a Windows-specific issue?

That suggests to me that it might be a regression related to https://gitlab.kitware.com/paraview/paraview/issues/18661, but I can’t be sure as I wasn’t running nightlies before that fix went in. I’m sorry for what may have been inadequate testing before I said that that fix had helped!

  • In versions 5.6.0 and 5.6.1, I can open and plot from FVCOM files of <2Gb, but anything over 2Gb fails.
  • In nightly builds 1554, 1598, and 1703 (those are the ones I’ve tested) I can open FVCOM files of any size - which is the fix from the issue above - but none of them will render.

I note that 5.6.1 came after nightly 1598, but that may not signify anything, depending on how versions are managed and what makes it in to numbered releases.

Just in case it matters I’m using the non-MPI version of the Windows download. If I should try the MPI version, let me know.

Thanks for looking into this!