Distribution of data for vtu format files


I use Paraview 5.10 and openMPI 4.0.3.

I want to distribute data in vtu format across MPI processes. I can’t seem to work out how it is supposed to distribute the data. Here is an example to show you my problem:

To do the distribution of the vtu data, I first execute the following pipeline using the builtin pvserver:

Wavelet > GenerateGlobalIds > RedistributeDataSet 

Le Whole Extent of the Wavelet is between -2 and 2 insterad of the default values -10 and 10 (for x, y, and z). The RedistributeDataSet has the option “Preserve Partition In Output” checked, and the numboer of partitions is 8. Otherwise, all options are at their default values.

I save the data as a .vtpd file (distributed_volume_vtu.zip (11.0 KB)), that links to several vtu files (as it should).
Now, I execute Paraview using another server, executed with mpirun:

mpirun -n 8 pvserver

I then open the vtpd file, and execute the following Pipeline on it:

Tetrahedralize > ProcessIdScalars > GhostCellsGenerator > GroupDatasets

The ProcessIdScalars has the option Cell Scalars checked, and the GroupDatasets produces a vtkPartitionedDataSetCollection.

faulty_pipeline_vtu.pvsm (537.8 KB)

Now, when I look at the data in the spreadsheet view, at the level of the GroupDataset, I find something I can’t make sense of:

For the point of Global Id 14, it appears twice in the spreadsheet, as it appears on two processes: one is a ghost point, the other isn’t.
For the point of Global Id 22, it appears twice in the spreadsheet, as it appears on two processes: however, neither are ghost points, they both appear as if they truly belong to their processes.

The screenshot below highlights the two points used here as well as shows their value in the spreadsheet.

This is what I don’t understand: are points on the border supposed to appear as if they truly belong to all processes they are one, or are they supposed to appear as ghost points on all but one process? Why are the two points cited here treated differently? Is this normal or a bug?

It can be noted that for vti files, i’ve seen that points on the border appear as ghost points on all processes but one.

Thank you for your time,

Eve Le Guillou

Hello again,

I saw that the recent release of Paraview 5.10.1 solved some distribution problems when it comes to the vtu format, so I updated my version and tried again, but it produces exactly the same results.

Many thanks for any help,

Eve Le Guillou