Enable AutoMPI in ParaView 5.11.2

I’ve downloaded ParaView-5.11.2-MPI-Windows-Python3.9-msvc2017-AMD64, and am trying to enable the “AutoMPI” option some of the earlier posts here had mentioned in order to run over multiple processors. I don’t find the option in this present version. Am I missing something? I’m new to ParaView, and would greatly appreciate your help with this query. Thanks!

Hi @Roger1198

AutoMPI has been deprecated and removed in ParaView 5.10 I believe.

Just run pvsevrer distributed manually instead.

.\bin\mpiexec -np 4 .\bin\pvserver

Then connect to it.

Hi, Mathieu. Thanks for the reply.

The command you’ve provided looks like something I’d have to type in an Ubuntu terminal. I’m running Win10. Is there another option for the above, or would you recommend re-installing ParaView on Ubuntu? Thanks

The command I provided should be run from a windows terminal.

Tried the command from the bin folder, and I the following error message. Does it not recognize the command? I did install the latest version of MS-MPI.

then it should be:

.\mpiexec.exe -np 4 .\pvserver.exe

Still no luck :frowning:

please type dir and share the complete result.

I’m presuming you want the contents of the directory? Here’s the terminal output in a sequence of screenshots:

Okay, I seem to have got it connected. Had to specify the full path of mpiexec.exe. I can now connect to the server. The change in post-processing speed is palpable!

1 Like