Error in loading vtk Shader Program


I am a new ParaView user and I noticed that whenever I try to load up a render view with Surface LIC display, an error code is showing up in the output window.
I am unsure as of what is causing the error, as the rendering seems to load up OK and LIC plot looks as expected.

Could you please have a look at the error message attached and advice on troubleshooting? As it seems to be graphics related, it might be worth mentioning that I am using a workstation with Nvidia Quadro K 2200 chip.

Kind regards and thank you for your help
ParaView Error Message.txt (25.8 KB)

Olek, could you post some step-by-step instructions for reproducing this error?

Doing the following does not lead to the error you posted:

  • Select Tools -> Manage Plugins…
  • Load SurfaceLIC
  • Add Wavelet source
  • Add Gradient filter
  • Change to Surface LIC representation.

Hello Cory,

Thank you for replying to this thread.

Steps to reproduce this error:

  • Select Tools -> Manage Plugins…
  • Load SurfaceLIC
  • Add Slice filter to exisitng source (volume mesh with calculate Velocity vector)
  • Change to SurfaceLIC representation
  • Change coloring to “U”.

As I mentioned the LIC plots show OK, although the error output message is concerning and annoyingly reproduces with every camera zomm / rotation / pan etc.


Hmm, I still can’t reproduce. Can you reproduce the error if you run paraview -dr (the -dr option disables any custom settings you may have)?

Oh, and which version of ParaView are you using?

So: both applying LIC to Wavelet source with Gradient filter and resetting settings to default (I am running on Windows so I used option Edit->Reset to default settings) and applying LIC to my source worked and did not yield any errors.

Any idea what custom setting could be causing an issue in the original case?

I am using ParaView 5.5.1 64-bit

Interesting. It’s hard to say which option may be interacting with Surface LIC negatively. Did you happen to back up your settings when choosing Edit->Reset? If so, mind sending me the backed up files? They should be under C:/Users/USERNAME/AppData/Roaming and have the extension .bak.

I would actually expect some of the options that default to on (depth peeling, FXAA) might be having an effect somehow, so it’s surprising that resetting to the default settings fixes things for you.

Hello Cory,

I am also seeing the same error whenever I use surface LIC. I am using paraview 5.4.1.

When I load my case file and click “Apply”, I see an error message
[ERROR: In C:\bbd\2d618e80\build\superbuild\paraview\src\VTK\IO\EnSight\vtkEnSightGoldBinaryReader.cxx, line 2267
vtkEnSightGoldBinaryReader (0000023852A76A20): Unknown element type "coordinates "]. In the selection dropdown list I am seeing velocity as "velocity(“partial”). But everything after this looks as expected.
Later when I load surfaceLIC, I see the message paraview error.txt (5.4 KB).
How can I fix this error?

Hello Saketh,

Please create a new topic to post about your issue. You can add a link to this one in your own topic if you want.