Error in socket processing : client-server

Hello everyone

I am trying to visualize the files on my cluster using Paraview on the client side (both use Paraview 5.4.0 version). On the client side, I use the binary version of Paraview. It unfortunately gives me a socket connection error, attached. I have tried several ways (discussed in this forum), but to no vain.

On the cluster :
srun --nodes=1 --time=00:30:00 --pty bash
mpirun -n 1 pvserver --use-offscreen-rendering -sp=26005 # port = 26005 (available, checked via netstat)

Displays :
Waiting for client…
Connection URL: cs://
Accepting connection(s):

On the client side, my server configuration says :
Server type : client/server
Host : (have also tried, doesn’t work)
port : 26005

error.txt (45.0 KB)


Are you absolutely sure that you are using the same version on both sides ?

This looks like a version mismatch to me as well. It would be really convenient if in future versions of ParaView we had the pvserver dump its version to stdout when getting called. We have this type of issue frequently and we have had to set up a more extravagent system of maintaining diagnostic data from the automated client server connection. It does seem that 90% of the problems are version mismatches we ParaView could do a better job of reporting, or at least dropping clues.

This issue seems related:

I am not sure if its because of the version mismatch - On the client side, I use Paraview 5.4.0 (binary distribution) while on the server side (cluster), the same version has been installed, see the screenshot below. Maybe, the one on the cluster has been built differently - is there any way for me to check this?


I also tried using a pvsc file to see if I can avoid this problem following this link. But, that too doesn’t work and I get this error :

ERROR: In /home/buildslave/dashboards/buildbot/paraview-pvbinsdash-linux-shared-release_superbuild/source-paraview/ParaViewCore/ClientServerCore/Core/vtkTCPNetworkAccessManager.cxx, line 413
vtkTCPNetworkAccessManager (0x1740600): 
Connection failed during handshake. This can happen for the following reasons:
 1. Connection dropped during the handshake.
 2. vtkSocketCommunicator::GetVersion() returns different values on the
    two connecting processes (Current value: 100).
 3. ParaView handshake strings are different on the two connecting
    processes (Current value: paraview.5.4.renderingbackend.opengl2).

As a sidenote, establishing a client-server connection used to formerly work in the server of my former institution, but I no longer have access to that. Hence, I have to use the current server and paraview installed on that only.