Error message: qt.qpa.xcb: X server does not support XInput 2

I have installed paraview version 5.7.0 on my WSL1 Ubuntu 20.04.2, but when I try to run the program by typing paraview, I get the following error message:

qt.qpa.xcb: X server does not support XInput 2
failed to get the current screen resources
( 0.971s) [paraview ]vtkXOpenGLRenderWindow.:296 ERR| vtkXOpenGLRenderWindow (0x7fffce7360c0): Could not find a decent config

( 0.976s) [paraview ]vtkXOpenGLRenderWindow.:516 ERR| vtkXOpenGLRenderWindow (0x7fffce7360c0): Could not find a decent visual

Loguru caught a signal: SIGABRT
Stack trace:
32 0x7fe1e958fdae paraview(+0x8dae) [0x7fe1e958fdae]
31 0x7fe1e93770b3 __libc_start_main + 243
30 0x7fe1e958fb5f paraview(+0x8b5f) [0x7fe1e958fb5f]
29 0x7fe1e9594d8a paraview(+0xdd8a) [0x7fe1e9594d8a]
28 0x7fe1e9590bfc paraview(+0x9bfc) [0x7fe1e9590bfc]
27 0x7fe1e91f8e70 pqParaViewBehaviors::pqParaViewBehaviors(QMainWindow*, QObject*) + 2480
26 0x7fe1e9173242 pqAlwaysConnectedBehavior::pqAlwaysConnectedBehavior(QObject*) + 258
25 0x7fe1e9173114 pqAlwaysConnectedBehavior::serverCheck() + 180
24 0x7fe1e79523fa pqObjectBuilder::createServer(pqServerResource const&, int) + 474
23 0x7fe1e7671c43 vtkSMSession::ConnectToSelf(int) + 131
22 0x7fe1e752198d vtkProcessModule::RegisterSession(vtkSession*) + 141
21 0x7fe1e4e2f4b2 /usr/bin/…/lib/x86_64-linux-gnu/ [0x7fe1e4e2f4b2]
20 0x7fe1e4d0dd3d vtkCallbackCommand::Execute(vtkObject*, unsigned long, void*) + 29
19 0x7fe1e77c2058 /usr/bin/…/lib/x86_64-linux-gnu/ [0x7fe1e77c2058]
18 0x7fe1e77ad8c1 /usr/bin/…/lib/x86_64-linux-gnu/ [0x7fe1e77ad8c1]
17 0x7fe1e8182300 QMetaObject::activate(QObject*, int, int, void**) + 2000
16 0x7fe1e78ef3e7 /usr/bin/…/lib/x86_64-linux-gnu/ [0x7fe1e78ef3e7]
15 0x7fe1e78ea2d6 pqServerManagerObserver::connectionCreated(long long) + 70
14 0x7fe1e8182300 QMetaObject::activate(QObject*, int, int, void**) + 2000
13 0x7fe1e79a1626 pqServerManagerModel::onConnectionCreated(long long) + 774
12 0x7fe1e78e8cf6 pqServerManagerModel::serverAdded(pqServer*) + 70
11 0x7fe1e8182300 QMetaObject::activate(QObject*, int, int, void**) + 2000
10 0x7fe1e91c1476 pqDefaultViewBehavior::onServerCreation(pqServer*) + 86
9 0x7fe1e57faf05 vtkPVSessionCore::GatherInformation(unsigned int, vtkPVInformation*, unsigned int) + 53
8 0x7fe1e57fad2a vtkPVSessionCore::GatherInformationInternal(vtkPVInformation*, unsigned int) + 58
7 0x7fe1e5710cfd vtkPVRenderingCapabilitiesInformation::CopyFromObject(vtkObject*) + 13
6 0x7fe1e5710cbe vtkPVRenderingCapabilitiesInformation::GetLocalCapabilities() + 430
5 0x7fe1e39715e5 vtkOpenGLRenderWindow::SupportsOpenGL() + 949
4 0x7fe1e3a05f97 vtkXOpenGLRenderWindow::WindowInitialize() + 23
3 0x7fe1e3a09903 vtkXOpenGLRenderWindow::CreateAWindow() + 2515
2 0x7fe1e9375859 abort + 299
1 0x7fe1e939618b gsignal + 203
0 0x7fe1e9396210 /usr/bin/…/lib/x86_64-linux-gnu/ [0x7fe1e9396210]
( 0.980s) [paraview ] :0 FATL| Signal: SIGABRT
Aborted (core dumped)

I have installed Ubuntu on my windows 10 laptop computer (Graphic card: NVIDIA GeForce MX130 and Intel® UHD Graphics) and I also have Xming installed. What is causing the problem and how to fix it?

ParaView is not compatible with WSL yet. Install the correct version of ParaView for Microsoft Windows 10:

Ok. It’s possible to use ParaView for Microsoft Windows on Ubuntu WSL1 ?

You can use ParaView for Microsoft Windows with Microsoft Windows. Why do you want to run it within Ubuntu WSL1 ?

Because I run my simulations on WSL1 and the simulation package is not available Microsoft Windows. So VTK is also working on WSL1? I also have error messanges when I run it.

Just share a folder between Microsoft Windows and WSL and use ParaView with Microsoft Windows:

Of course, another alternative is to use a proper linux distribution.

@cory.quammen: We ought to write a Tips and Tricks about the WSL situation.


I am trying to run paraview gui using Xming on a cluster. I use putty to access the cluster. X-Forwarding is working as I tested it with xlock. When i enter the command “paraview”, the same error pops up.

My guess is that the OpenGL setup available through that X setup is not suitable. Can you get more information about the GL setup? Perhaps glxinfo?

This thread seem to have a better solution.