Error reading cell array offset header

Hey there!
I’m new at Paraview and I have a problem. I tried to open the following .vtk file, but there comes out the error: Reading cell array offset header. Tried to fix but it actually doesn’t works and i have no further ideas how to change. I’d be pleased about your help!
Best regardsKoerper1.vtk (134.1 KB)

sorry, wrong version: here with cell types Koerper1.vtk (140.3 KB)

I don’t know what’s new with the 5.1 version of the legacy VTK file format, but your file seems to be missing the CELL_TYPES section. I think at the bottom of your file you need something like this.


Where 8 is repeated 2117 times.

This section is present in the new version of the file that @JanPara uploaded above in the discussion

I thought I was looking at the new one, but apparently I was not.

The problem might be that the file declares the wrong version. If you change the first line to

# vtk DataFile Version 4.2

then ParaView can read it. Here is the changed file: Koerper1-changed.vtk (140.3 KB)

I don’t know how Version 5.X of the legacy VTK files work as I have not seen the documentation, but there appears to be some new offset stuff added to it that this file does not have.

There is probably still something else wrong with the file. When I load this file into ParaView the cells look very wrong.

Thanks a lot ! seems that something with the mesh/connectivity is wrong

It’s funny that this text file VTK format officially called legacy. In fact, this is the main way to import data from third-party unsupported programs into Paraview