Error reading in tecplot dat file

Hi, apologies if this has been asked before - i searched but couldn’t find an answer. I’m attempting to read in a .dat file with the Tecplot reader but keep encountering errors. The SOLUTIONTIME and STRANDID warnings can be solved by removing them from the header, but it doesn’t fix the record type error. That “record” is the first value in the dat file. If I read in as a Tecplot table the importer picks it up fine. Am I missing a simple formatting issue?

Unlikely to be the issue, but this dat file was created by FUN3D. And I’ve replicated the error in Paraview 5.6 on Linux and Paraview 5.7/5.8 on Windows.

Error:

Dat File:

EDIT
also if i remove the strandid and solutiontime, a new warning about FEBLOCK being supported pops up but the same error occurs

Hi,

I was also struggling with tecplot dat files. This is what I figured out after searching info in many blogs:

• X, Y and Z array headers MUST NOT have other characters like [mm]. It must be simply “x”, “y” and “z”.Paraview also accepts this: “Z, mm” and this “x/c”
• This parameter is not allowed by Paraview (it must be deleted from the file): “ZONETYPE=…”
• “STRANDID” and “SOLUTION TIME” are currently unsupported by Paraview but they can be left in the file (it gives only a warning message)
• Comments are allowed by using “#” (like Python)

Tecplot format manual:
http://www.hgs.k12.va.us/Tecplot/Documentation/tp_data_format_guide.pdf

Regards,

Miguel

Can you share a failing file ?

A couple of changes are needed to read this in properly.

First swap the i= & j= to n= & e= respectively. These are the number of nodes/elements in each zone, so you may have to change this multiple times if your file has multiple zones.

Next, an element type needs to be added after the zonetype by specifying, et=. This will be something like triangle or quadrilateral for 2D. I haven’t tried 3D elements, but tetrahedral and or brick would be potential options.