Error SSE3 with paraview-superbuild and ospray

Hi all,
I am trying to build Paraview 5.9.1 on linux system with superbuild and with some advanced options activated, among others : ospray and mpi.

Everything was ok until ospray part which required to install “openimagedenoise”. This module encountered an error about SSE3 and I didn’t find any solutions to solve enable it.

Anyone else to help me ?

Below the complete error :
[ 60%] Built target ospraymaterials
[ 60%] Performing build step for ‘openimagedenoise’
[ 1%] Building CXX object common/CMakeFiles/common.dir/platform.cpp.o
In file included from /my_path/PARAVIEW/5.9.1/superbuild_591/superbuild/openimagedenoise/src/common/platform.h:19:0,
from /my_path/PARAVIEW/5.9.1/superbuild_591/superbuild/openimagedenoise/src/common/platform.cpp:4:
/usr/lib/gcc/x86_64-redhat-linux/4.8.5/include/pmmintrin.h:31:3: error: #error “SSE3 instruction set not enabled”
'# error “SSE3 instruction set not enabled”
gmake[5]: *** [common/CMakeFiles/common.dir/platform.cpp.o] Error 1
gmake[4]: *** [common/CMakeFiles/common.dir/all] Error 2
gmake[3]: *** [all] Error 2
CMake Error at /my_path/PARAVIEW/5.9.1/superbuild_591/superbuild/sb-openimagedenoise-build.cmake:47 (message):
Failed with exit code 2

make[2]: *** [superbuild/openimagedenoise/stamp/openimagedenoise-build] Error 1
make[1]: *** [superbuild/CMakeFiles/openimagedenoise.dir/all] Error 2
make: *** [all] Error 2

Many thanks for your support,

openimagedenoise is recommended but not actually a requirement for ospray. It is a bug that paraview’s superbuild thinks it is.

My recommendation is for you to edit lines 14 and 24 of this file in your superbuild source to remove the dependency.
projects/ospray.cmake · master · ParaView / ParaView-Superbuild · GitLab (

1 Like

Hi Dave,
Thanks for your answer. Good news, I will try it !

For others, if OpenImageNoise is required, I found a solution by adding the flag “-msse3” to the c++ compiler in the cmake file (CMakeCache.txt) of the module.

See the file below:

add -msse3, line 41 of this file: “CMAKE_CXX_FLAGS:STRING=-fPIC -std=c++11 -msse3”

Many thanks and have a good weekend !

1 Like