error while running paraview executable

I installed the paraview v5.12.0 on centos stream 8. When I tried to run paraview, I encountered an error below.

“./bin/paraview: error while loading shared libraries: cannot open shared object file: No such file or directory.”

Actually, I tried to link to It worked but another error occurred like

“./bin/paraview: symbol lookup error: /root/paraview_build/bin/…/lib64/ undefined symbol: PyExc_ImportError”

So, I just unlinked it because I don’t know what I did is right and the second error also include the “” similar to the first error. Does any one who has a clue about the problem?

Thanks in advance.

Do you have LD_LIBRARY_PATH set in your env vars ?

Thank you for reply. I don’t understand your question properly. Should I add something to LD_LIBRARY_PATH to run paraview?

The symptom you are having shows that the wrong lib are being picked up, so you may want to ensure “LD_LIBRARY_PATH” is NOT set.

I installed the paraview v5.12.0 on centos stream 8.

How did you install it ?

Mostly, I just followed the link “” for centos 7.

First, I installed packages like
sudo dnf install python3-devel openmpi-devel mesa-libGL-devel libX11-devel libXt-devel qt5-qtbase-devel qt5-qtx11extras-devel qt5-qttools-devel qt5-qtxmlpatterns-devel tbb-devel git

After that I just followed the link like

git clone
mkdir paraview_build
cd paraview
git checkout v5.12.0
git submodule update --init --recursive
cd …/paraview_build

finally I didn’t use ninja but make like

make -j 16

The above is all what I did. After make, I just tried to run paraview but it failed.

Any specific reason for you to build ParaView instead of using the paraview binary release from ?

There was no specific reason. I just thought that they are just different ways to install it.

What is the difference between them?

I downloaded binary you said before building it. I just tar it and I can run it without any problem. Thank you very much for your help Mathieu.