Error with "save animation"

Dear all,

I tried for the first time the command “save animation” in paraview and got these errors:

lH8wFv/paraview-5.4.1+dfsg3/ParaViewCore/Animation/vtkSMSaveAnimationProxy.cxx, line 166

vtkSMSaveAnimationProxy (0x562f92b65e70): The requested resolution '(1544, 802)' has been changed to '(1544, 800)' to match format specification.

Generic Warning: In /build/paraview-lH8wFv/paraview-5.4.1+dfsg3/VTK/IO/FFMPEG/vtkFFMPEGWriter.cxx, line 449

Problem encoding frame.

ERROR: In /build/paraview-lH8wFv/paraview-5.4.1+dfsg3/VTK/IO/FFMPEG/vtkFFMPEGWriter.cxx, line 620

vtkFFMPEGWriter (0x562f92bcf510): Error storing image.

Do you have any suggestion?

I posted the same question also here:

The problem is that the writer only supports writing out an image of the same size across the entire animation. This seems to be common to all movie writers (except maybe the AVI writer?). I don’t know how to force a size for screenshots. @cory.quammen or @utkarsh.ayachit?

You are actually seeing two issues.

  1. This is actually a notice, saying that the .avi format requires the X and Y to be 0 mod 4. ParaView is warning you that it is changing size out the output image. This is normal.

  2. No clue. Looks like a bug. I would recommend you update to a newer version of ParaView (the new, shiny 5.6.0), try again, and let us know if there is an issue?

Which web application were you using do save the animation?

@jourdain I believe it is in the original post, and is paraview-5.4.1. Jacobo - is it a custom build, or is it from Kitware?

That question seems to be only related to ParaView (Qt) and has nothing to do with Web even if the topic selected is “Web Support”.

Anyhow, this does not affect ParaView Visualizer, ParaView Lite, ParaView Divvy or ParaView Glance.

I’m wondering if the topic “Web Support” was used because the question was asked using a Web browser?

I’ve moved it to the ParaView Support group.

1 Like

Dear all,

Thank you for your answers!

I am using ParaView 5.4.1 in Ubuntu. I’m not used with Ubuntu, so I only tiped apt paraview and it installed this version. Now I’ll try to update it to 5.6.0 as you suggested and let you know!

@jourdain I’m sorry, I misunderstood the forum organization!

1 Like

It works! Thank you very much for your help! Now I had another issue…I downloaded both source and bin. I can’t use source (I don’t know how to manage it, I tried looking on the internet but I ended up with a bit of mess), but how can I install it from bin? So that I don’t have to always launch it from executable…