Evenly spaced streamlines 2D error

I have an error when I try to use EvenlySpacedStreamlines2D.
I’m trying to show pvtu 3D cell data with EvenlySpacedStreamlines2D.
So I tried following methods.

  1. Open data.
  2. Filter - CellDatatoPointData
  3. Filter - Slice - Z normal
  4. Filter - Calculator - “MS_B(T)_X”*iHat+“MS_B(T)_Y”*jHat
  5. Filter - EvenlySpacedStreamlines2D

Then error message is opened with no output data.
This is the error message.

ERROR: In C:\glr\builds\paraview\paraview-ci\build\superbuild\paraview\src\VTK\Common\ExecutionModel\vtkExecutive.cxx, line 753
vtkPVCompositeDataPipeline (0000010D3E253180): Algorithm vtkEvenlySpacedStreamlines2D(0000010D6FBAA600) returned failure for request: vtkInformation (0000010D78635990)
Debug: Off
Modified Time: 24541029
Reference Count: 1
Registered Events: (none)

I tried in Paraview 5.10.1, Paraview 5.11.0, and Paraview Master 5.11.0-RC1.
And no success.

I attached my pvtu file.
Air2.zip (2.0 MB)

Any reply would be helpful.
Thank you.


After cutting at z=0.0005, specify Start Position in EvenlySpacedStreamlines2D as
I was able to draw streamlines on only one piece of the surface. If the surface is divided into several pieces, it may be necessary to apply EvenlySpacedStreamlines2D to each piece.

Dear Kyoshimi,

Thank you very much!
It was worked. But still I can’t draw other pieces, even though I set Start Position in EvenlySpacedStreamlins2D.
I will keep trying.
Thank you.


I have automated this with a python script.
streams.py (5.7 KB)

To use it, place streams.py in the same folder as vg_VolTs_VTK_Air2_5.pvtu and in ParaView 5.10.1, specify streams.py from “File > Load State…”.

Dear, Kyoshimi

I didn’t know about “Connectivity” and “Threshold” filters.
Actually, I modified the part of file location in your streams.py file. Then it worked.

Maybe I should study those filters and your script.
Thank you very much.