Exporting to x3d

Hi guys.

I have a little problem when I try to export a file to .x3d. The error I get when I try to export is:

ERROR: In C:\bbd\ecd3383f\build\superbuild\paraview\src\VTK\IO\Export\vtkX3DExporter.cxx, line 149
vtkPVX3DExporter (000002519C876CF0): unable to open X3D file C:/Users/Kenneth’s Leket?y/Desktop/ParaView-5.8.0-RC1-Windows-Python3.7-msvc2015-64bit/ParaView-5.8.0-RC1-Windows-Python3.7-msvc2015-64bit/bin/TestUtvik.x3d

The way I tried to export it was “File” -> “Export scene…” -> names the file and choose .x3d as files of type.

The files I want to exports are 3 .vtk files.

Hope someone can help me with my little problem.

No problem here.

Could you try to export to a path with only ANSI char in it where you have permission to write ?
eg: C:/tmp

1 Like

oh it worked. Thank you!

This bug is being worked on by @todoooo.

How timely. Is the latest build of Paraview being used?

I am using ParaView 5.8.0-RC1

You’ll need to build Paraview against the latest version of VTK in the master branch to fix this or wait for a new official release.

Note that you can always get "master’ on the paraview.org webpage, under Downloads, then Nightly.

1 Like

ParaView 5.8.0 will not include the fix. Nightly is your best bet until 5.9 comes out, which is scheduled for rough September 2020.

Hello Everyone.

I tried to do the same but I got a different message

ERROR: In C:\glr\builds\paraview\paraview-ci\build\superbuild\paraview\src\VTK\IO\Export\vtkX3DExporter.cxx, line 149
vtkPVX3DExporter (000001B8CD348370): unable to open X3D file C:/Program Files/ParaView 5.10.0-RC1-Windows-Python3.9-msvc2017-AMD64/blender.x3d

the paraview it is for Windows because also I could not install for Linux

Thank in advance for any Help


You probably need administrator rights to write to C:/Program Files/ParaView 5.10.0-RC1-Windows-Python3.9-msvc2017-AMD64/. Choose a different directory in the file dialog to save it somewhere else.

1 Like