failure to makeParaview, kwsysDateStamp.cmake problem

Hello everyone:
I tried to install openFoam8.0 with third_party. All the installation is executed following the instruction of (OpenFOAM Repo: 4. Third Party Software | OpenFOAM). but when making paraview, some error occur as following:
I’m wondering how to tackle those problems? hope some one can help me, thanks in advance.

log.makepv (146.3 KB)

Total Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 51.5M 100 51.5M 0 0 246k 0 0:03:33 0:03:33 --:–:-- 93149
sed: can’t read /share/home/zhangzz/OpenFOAM/ThirdParty-8/ParaView-5.6.3/VTK/Utilities/kwsys/kwsysDateStamp.cmake: No such file or directory
CMake Warning:
Manually-specified variables were not used by the project:


Processing wiki sources
Processing wiki filters
Processing wiki writers
Processing wiki readers
Cannot mix incompatible Qt library (version 0x50906) with this library (version 0x50907)
/bin/sh: line 1: 105534 Aborted (core dumped) /share/home/zhangzz/OpenFOAM/ThirdParty-8/platforms/linux64Gcc/qt-5.9.6/bin/qhelpgenerator /share/home/zh64Gcc/ParaView-5.6.3/Applications/ParaView/Documentation/paraview.qhp -o /share/home/zhangzz/OpenFOAM/ThirdParty-8/build/linux64Gcc/ParaView-5.6.3/Applications/ParaVie
make[2]: *** [Applications/ParaView/Documentation/paraview.qch] Error 134
make[1]: *** [Applications/ParaView/Documentation/CMakeFiles/vtkParaViewDocumentation.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs…
make: *** [all] Error 2

Welcome to the ParaView community Zhuang.

Can you just turn off the ParaView build, and download the binaries? Binaries are found here, i.e., Downloads. The version of ParaView you are trying to build is a few years old.

Thanks for reply. I am so glad that someone give me a hand in this problem.

I’ve download “ParaView-5.10.0-MPI-Linux-Python3.9-x86_64”, but it still does work. After download the package, I just change into the paraview_pack/bin/ directory and run paraview, another error comes as:
/ParaView-5.10.0-MPI-Linux-Python3.9-x86_64/bin/paraview-real: /lib64/ version `ZLIB_1.2.9’ not found (required by /share/home/zhangzz/ParaView-5.10.0-MPI-Linux-Python3.9-x86_64/bin/…/lib/
pls forgive me as I am new in linux. maybe there are something wrong in my work,but i can not deal with it. I wonder whether this is the correct way to install run paraview.

another problem is that:
the administrator has install paraview4.4 via yum, and others can use paraview4.4 freely. but for me, another error comes “paraview: Fatal IO error: client killed”. how this happend? is it because that I have installed the paraview in Third-party though not succeeded?

libz is provided by ParaView package but for some reason your system is being loaded, you can try the following:

cd /ParaView-5.10.0-MPI-Linux-Python3.9-x86_64/
LD_PRELOAD=./lib/ ./bin/paraview


Too old, do not use.

Thanks for your reply.
i have tried the commands, but some errors comes again as following:

qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: xcb.

error: exception occurred: Subprocess aborted

maybe some plugin not installed or not properly installed, I am trying to dealing with those problem. Thanks again.

You definitely have a system issue. I would recommend trying on another computer first.