FreeCAD ParaView 5.4.1 and 5.7.0 Problems

First of all, I have little experience but had fantastic service from PV 5.4.1 before recent changes to FreeCAD (0.18). Similar problem. I can start PV 5.4.1 from or outside FreeCAD but cannot open a file. It just hangs up if I try to open or indeed do anything from the menu bar. All I can then do is end task from task manager. I installed PV 5.7.0 and it works but having problems using it. Getting 5.4.1 working would be a big help

It is not clear, are you working with ParaView downloaded from https://www.paraview.org/download/ ?

Can you share the file that does not work ?

Yes, downloaded files have the described problem as well as that install from FreeCAD’s BlueCFD-Core The problem is the same. I need to run FreeCAD again to obtain a new ParaView file so will post that later. Thanks!

Tried earlier but post not showing. This is the ParaView file that FreeCADD opens.
pv.foam (41 Bytes)

But is this what you want me to provide? It can’t hold the full case data.

PV 5.4


PV 5.7

PV 5.7 works fine but cannot do anything in 5.4. It scrashes if I select anything.

The Glyph filter has changed in ParaView 5.7, you have to set the OrientationArray.

Okay, I haven’t looked into that but are you suggesting that I now cannot use 5.4 any more?

I do not understand.
What are you trying to achieve ?
What does not work ?

Hi Mathieu

As I suggested, I can launch 5.4 and it woks fine but I cannot access any menu items such as Save State and Load State. If I select anything from the “File” menu item PV 5.4 just crashes and I can do nothing at all. I cannot even open “File” again to exit and must use Ctl,Alt,Dell to close via Task Manager.

PV 5.4 still works but I cannot use it and save any results. PV 5.7 works fine but clearly I have a new learning process to go through. No problem there, I love learning, but would love to also have PV 5.4 available to continue my work while switching. I love the open sourse environment and love to help it and you all along, I’m massively gratefull for your support.

Thanks and hope this explains better.

Michael

Much clearer, thanks.

Do you happen to have a specific Locale (language) on your computer ?
Do you have funny network share on your computer ?

Maybe related :
https://public.kitware.com/pipermail/paraview/2009-March/011638.html

Sorry my understanding is very lacking but please find the attached as a possible explanation.FreeCASD Paraview Forum 10-10-19 - Rev P1.pdf (1.0 MB)

I’ve also posted this on my FreeCAD CfdOF focus topic.

Many thanks and please let me know if I can do any more.

Michael

Do you have a special network share on your computer ?

I just have my notebook/laptop PC connected to my personal Western Digital My Cloud server. But all the work I have done is stored on my C: drive where FreeCAD CfdOF stores my data in my “temp” folder.

Oh, sorry, my inexperience perhaps here. Are you asking me if I can share my computer with you? I recolect being able to do that at my company before I retired but no idea how to do that from home.

I just have my notebook/laptop PC connected to my personal Western Digital My Cloud server.

You issue may be related to that. Can you disconnect/remove it ?

Are you asking me if I can share my computer with you?

Not at all

Can you disconnect/remove it ?

That done. Switched server off completely and got the same result, No orientation array in Glyph Properties.

Still very strange PV 5.7.0 Glyphs and PV 5.4.1 still crashing with any menu selection.

Michael

No orientation array is an option, it doesn’t mean that there isn’t a vector array to use for orientation. Click on that popup menu to choose a different array.

@mcrossleyuk : I’m confused, I was trying to help you for this bug :

As I suggested, I can launch 5.4 and it woks fine but I cannot access any menu items such as Save State and Load State. If I select anything from the “File” menu item PV 5.4 just crashes and I can do nothing at all. I cannot even open “File” again to exit and must use Ctl,Alt,Dell to close via Task Manager.

PV 5.4 still works but I cannot use it and save any results. PV 5.7 works fine but clearly I have a new learning process to go through. No problem there, I love learning, but would love to also have PV 5.4 available to continue my work while switching. I love the open sourse environment and love to help it and you all along, I’m massively gratefull for your support.

So, I understand that disconnecting does not fix it ?

Yes, disconnection has not fixed it.

Thank you cory.quammen.

I saw that and did change to Decomposed array that gave me the scalar and vecor properties I require. But I now have a lot to learn about useing them in the new 5.7.0 version. At the moment I cannot produce the glyph images I could in 5.4.1.

I actually managed to generate a clip and glyph that gave me thye omega pattern on the clip surface. Made great progress today and can make progress now. Key thing is I can now save and load states. I now need to spend some time obtaining my velocity glyphs. But your help is again greatly appreciated.

I’ll keep looking.


Thank you

Michael