graphic card issue ?

Hi everybody ! enjoy your sunday !
Some time when I have to post process a polymer (using spherical glyph as atoms and tube for the virtual connection) if the polymer chain going to collapse and the atoms are very close each other I have to reduce the ray of the glyph sphere I don’t obtain a good sphere but a rough approximation like in the pictures

Is a problem of not so good graphic card or there is some tips or trick to make it a pesonable good sphere ?

No body know ? how can I solve ?

I don’t know. However, I would guess that this is not a graphics card issue. If possible, please add an example data file, with steps to reproduce the issue.

If I had to guess (and this is just a guess without more information) is that your data takes a very small region of space (somewhere around of 1e-130). The coordinates get stored fine in double precision, but the graphics system has to convert the double precision to single precision, and single precision floating point numbers cannot hold numbers that small with precision.

I would try running the Transform filter and scaling up the physical space by a large number to get the bounds closer to 1.

oh right ! try this vtk file , using glyph filter and ray of sphere 0.2 try to get a good sphere!

fpchains.000000400.vtk (768 Bytes)

I tried loading your data into ParaView 5.6, and it worked fine. I then tried again in an older version of ParaView (5.2) and saw rendering issues similar to what you report. So my first suggestion is to update to the latest version of ParaView if you can. That might solve the problem for you.

I notice that your data has bounds around 100 wide but is offset by around 10 million. If you cannot update your version of ParaView, you could try translating your data to center around 0. Add the Transform filter and change the Translate field to [ 79781000, 62944000, -14140000 ]. That solved the issue on my computer with ParaView 5.2.

thank you so much !!! I will try !

which version did you download ? there is one named “osmesa” … while for the 5.4 there is the openGL version … does 5.6 use openGL ?

There is only one version of ParaView 5.6 binaries. With ParaView 5.4 there was a transition from an old legacy OpenGL to more modern OpenGL features. By ParaView 5.6 the old legacy OpenGL support was dropped.

I try to download paraview 5.6 but i got the same problem :frowning:

Does translating the data solve the issue?

Not really … :frowning:
when I translate the data does it metter if i leave selected the marks options ‘scale’, ‘rotating’ and of course translate ? I left the value of scale = 1 ,1,1 ; rotate = 0 , 0 , 0

No, leaving scale and rotate the same is correct. Are you doing the translate before the glyph? It shouldn’t matter, but it might.

Some other things you can try is to turn on OSPRay rendering. (The option is on the bottom of the View properties.) That will turn off any graphics hardware you have. If that does not change the behavior, then the problem is probably not with the rendering.

I’m doing the transalte over the data ! so before the glyph , I didn’t found OSPRay renderng is in the view menu ??

No sorry I found it !