I cannot read a .vtp file I could open yesterday. Can someone try to open it?

Hi all,

I am trying to open a .vtp file I was able to open yesterday… I am using Arch Linux and Paraview, I just performed the usual system update, no fancy stuff.
It is even stranger because I cannot open .vtp files saved from vtk files which instead open correctly.

I am attaching the problematic vtp file, error message and Paraview information at the bottom of this message.

Thank, I am by no means an expert but this seems a bug to me.

Edit: The problem with saving a vtp from a vtk file seems to be related to the mode of exporting, Ascii and Binary seem to work, the Appended apparently does not. I am attaching a picture.

The problem with the attached .vtp file persist: it does not come form a vtk that I have and yesterday it was read without problems, can anyone try to open it?

cylinder.vtp (5.2 KB)

ERROR: In vtkXMLParser.cxx, line 375
vtkXMLDataParser (0x61d4aa65edb0): Error parsing XML in stream at line 44, column 89, byte index 3064: not well-formed (invalid token)

ERROR: In vtkXMLReader.cxx, line 520
vtkXMLPolyDataReader (0x61d4a95182d0): Error parsing input file.  ReadXMLInformation aborting.
Client Information:
Version: 5.11.2
VTK Version: 9.2.20220823
Qt Version: 5.15.12
vtkIdType size: 64bits
Embedded Python: On
Python Library Path: /usr/lib/python3.11
Python Library Version: 3.11.7 (main, Jan 29 2024, 16:03:57) [GCC 13.2.1 20230801]
Python Numpy Support: On
Python Numpy Path: /usr/lib/python3.11/site-packages/numpy
Python Numpy Version: 1.26.3
Python Matplotlib Support: On
Python Matplotlib Path: /usr/lib/python3.11/site-packages/matplotlib
Python Matplotlib Version: 3.8.2
Python Testing: Off
MPI Enabled: On
Disable Registry: Off
Test Directory: 
Data Directory: 
SMP Backend: TBB
SMP Max Number of Threads: 16
OpenGL Vendor: Intel
OpenGL Version: 4.6 (Core Profile) Mesa 23.3.5-arch1.1
OpenGL Renderer: Mesa Intel(R) Graphics (ADL GT2)
Accelerated filters overrides available: No

Connection Information:
Remote Connection: No

Works fine with ParaView 5.12.0-RC2 here:

Hi @nihil39, could you try resetting your settings through the Edit → Reset to Default Settings menu option? If you choose the “Yes, and backup current settings”, that would save a file I may be able to look at to get a clue how settings sometimes get corrupted. and lead to strange behavior like this.

Here they are, Thank you.

ParaView5.11.2b.ini (12.1 KB)
ParaView-UserSettings_b.json (3.2 KB)

I don’t know if it is a problem related to a Linux version of something.

dpaste/FkN2m (Plain Text) ← Dpaste link for .ini file
dpaste/Mm2Yv (Plain Code) ← Dpaste link for .json file

I’m using the Linux version.

Ok, maybe different libraries versions because we are using different Linux distributions (Arch Linux here), I don’t know.

Or maybe my Paraview version does not support a more recent version of something that Arch Linux has automatically updated, you are using Paraview 5.12, but mine are just wild guesses, shots in the dark.

Me too, I’m using the binary release from https://paraview.org/download

If it’s not an inconvenience for you, given the fact that you are already using Arch, could you try to install the stable 5.11.2 version that is in the Arch repositories? I really can’t understand what is happening in my system which seems, for the rest, to be working fine.

If it is not possible for you, never mind.

Thank you.

I confirm that this is not working with paraview package from archlinux package manager.

Looks like an issue with the XML parser, which is using system expat in your case and which is not the case of the binary release.

You may want to open an issue on the arch linux package itself and link to this discussion.

1 Like

Thank you, I asked for a username and password to file a bug for the Arch Linux package. Apparently for spam reason you have to request an account by mail. I will then post a bug and link this thread. I will report here if it is fixed or not.

As an adidtional piece of information, I’m having the same issue in Debian testing/unstable, also with ParaView 5.11.2(+dfsg-6+b1) and libexpat1 2.6.0-1 (not sure which version of libexpat is being used by Arch). I’ll report the issue to Debian and link to this thread.

1 Like

BTW I tried downgrading libexpat1 on my Debian installation to 2.5.0-2+b2 and it solved the issue for me, which seems to confirm that the issue is in the expat library rather than in ParaView itself.


The expat version I am using now, which causes the problem, is:

core/expat 2.6.1-1 (116.3 KiB 414.4 KiB) (Installed)
An XML parser library

So it is a bug with libexpat 2.6, not with Paraview, right?
Maybe Paraview binary version 5.12-RC is using libexpat 2.5?

Yes, ParaView 5.12.0 is using expat 2.5: https://gitlab.kitware.com/paraview/common-superbuild/-/blob/6999b3a595e1816f40e8018e8ee1aa97c1783452/versions.cmake#L646

Thank you, if I understand it correctly, Arch Linux tries to compile ParaView against the system version of expat which has this issue. But maybe the problems is related to vtk too from what I can understand reading the bug report in Arch here (I tried to file the bug but they didn’t provide me an account, I wrote them a week ago, but luckily someone filed it for me. :slight_smile: )

Maybe a useful information: Paraview 5.12 has been released in Arch Linux and the problem is still here. I think Arch Linux developers are not that keen on using the internal version of the package libraries in general. In our case the internal version is expat 2.5 but the Arch Linux package build is linked against the expat system version (2.6.1) which causes the bug.

Which is expected of ArchLinux. We need to fix it.

I have a question/curiosity, I’m not an expert at all. Paraview does not require a specific version of expat for particular reasons, right? Are you using expat 2.5 because it was the latest release when you started to write the code for Paraview 5.12?

By the way I think that if the problem is expat maybe expat developers have to fix the bug, I don’t know if it would be easier for us Arch Paraview user to use in the meantime the binary package downloadable from the Paraview website.

edit: I have just read that the bug is on VTK and someone is working to solve it.

Yes, exactly so: https://gitlab.kitware.com/paraview/common-superbuild/-/commit/6744ee3df360a374ec66f0793def67b379aca8c3

expat 2.6.0 came out just about a month before ParaView 5.12.0.