Ignoring voids when Interpolating the 2D points dataset on a regular grid

I am using point plane interpolator to interpolate point properties (from SPH results) on a regular grid; however, I like to have the voids in the domain as zero or null in the dataset. But point plane interpolator interpolate the voids as well. Any suggestion is appreciated. Bests,

Which Kernel are you using? If you are using the VoronoiKernel, then that will fill the space with a Voronoi diagram (finding regions closest to each input cell) leaving no voids. However, any of the other kernels will basically splat values with a given Radius, and that can leave voids.

Thanks for your response. I have tried all the available Kernels; but all of them fill the void. Not sure what is wrong.

Have you tried playing with the Radius parameter? That specifies how big of a volume each point will cover. It defaults to 1, but if you have a small boundary of points, that might mean total coverage, in which case you would have to lower the Radius to some small fraction of the boundary.

Hi Kenneth,
Sorry for late return, and thanks for your guide. I tried what you suggested, unfortunately it didn’t work. Below is the figure of the actual domain and the interpolated one, and the second photo is the setup I used. However, I have tried other kernels with several radius. I appreciate you help.

Can you be more specific about what is wrong with the output? In your original question you said you were find with zeros in the voids of your data set, and it looks like the interpolation is filling the void of the post with 0. The colors look a bit different, but it could just be a difference in the lighting being used. (See for example Color legend does not agree with color displayed in data .)