Import paraview (5.8.1) module in Python 3.7 on Anaconda Juypter notebook using MacOS

Hello,

I have a python script that I am attempting to run in Anaconda Juypter Notebook using MacOS Catalina.

On a line that tries to import Paraview that says:
“from paraview.simple import *”
An error occurs that says:
“No module named ‘paraview’”

I’m really new to ParaView and Python as I am not too sure how to set the paths as stated in some of the topics. Or When typing out “pvpython” onto the terminal, this was what I got from the terminal as stated below.

(base) raphaels-mbp-2:~ Raphael$ python
Python 3.6.5 (default, Aug 23 2020, 11:53:50)
[GCC 4.2.1 Compatible Apple LLVM 11.0.3 (clang-1103.0.32.62)] on darwin
Type “help”, “copyright”, “credits” or “license” for more information.

pvpython
Traceback (most recent call last):
File “”, line 1, in
NameError: name ‘pvpython’ is not defined

Lastly, I have tried following the steps as shown in this link below:

Link: https://gitlab.kitware.com/paraview/paraview/blob/master/Documentation/dev/build.md#complete-compilation-guide

However, when typing “git submodule update --init --recursive”, this was the error I got on the terminal.

git-lfs filter-process: git-lfs: command not found
fatal: The remote end hung up unexpectedly
Unable to checkout ‘f2aa6ad5be1a97e3fb41ef4680ee2c76c3434ac0’ in submodule path ‘VTK/ThirdParty/vtkm/vtkvtkm/vtk-m’
Failed to recurse into submodule path ‘VTK’

Really not sure what to do and how to resolve this issue. Currently, I know I have the anaconda platform installed (Using Juypter Notebook) along with ParaView v5.8.1.

Do kindly hope someone could help me with this as I am trying my best to understand how this works.

pvpython is an executable, not a command to be run inside of a python shell.

You’ll need to install git-lfs to download VTK-m’s testing data.

I know it’s been a long time since you asked this question. However, I faced the almost same problem when I tried to download source code by following instructions in ParaView:Build And Install and thought it might be helpful for others. The steps I followed are:

  1. brew install git-lfs
  2. cd paraview
  3. git clone --recursive https://gitlab.kitware.com/paraview/paraview.git
  4. git submodule update --init --recursive

Hi @baysalse ,

This guide is out of date, please here: https://gitlab.kitware.com/paraview/paraview/-/blob/master/Documentation/dev/build.md

Also, ParaView do not use git-lfs at all.

1 Like

Only if you ignore the VTK-m nested submodule. But it is part of the recursive git repo, so it can be necessary.

Right, I forgot about that.

I wonder if we could disable lfs in the vtkm submodule, VTK nor ParaView are not using the lfs data, is that correct ?