Importing time series after loading a state in 5.4.1

In the past, I had been using Paraview (version 5.0.1 64-bit in Ubuntu 16.04) to analyse simulation results. In the simplest case I have a (x,y,z) file with simply 3 column vectors separated by a space, with N lines for N particles to plot. Then, I use TabletoPoints and then Glyph to have a 3D view of N particles. My data is saved in simple text files with the format “col*.txt” where * is the time step like 001 ,002…100 (the actual numbering is not sequencial).
After saving the state, I was able to load the state again and apply all my filters into different time series files. Therefore, I was able to see the time evolution of the files using one single state file.

Now, I am using Paraview 5.4.1 64-bit in Ubuntu 18.4. With the new 3-options version, I try to do the same by choosing the "Chose File Names " [*] and selecting all the files with the correct format. But I don’t get the time series, instead, only the first time step.

I was wondering if that could be a bug, or if I need to change settings.

In any case, thanks and sorry if the question is too simple. This is my first post here. The actual paraview pipeline includes .vtk reading, isosurfaces and more, but I have tried to use a minimal example and see if it fails, as it indeed does.
] Original message was wrong, stating “Use” instead of “choose”.

I’m a little confused. Which option are you using? “Use File Names from State”, which doesn’t let you choose different files, or “Choose File Names”, which does let you choose different files?

1 Like

I was mistaken: the option I use is “Choose file names” in order to choose the set of files I want to import.
I am sorry for the mistake and I will edit the original message.

I reproduce your issue and it is a nasty one.

Please create an issue on our gitlab.

1 Like

Dear Mathieu,
Thanks, I will submit it. In any case, I think I will try to downgrade to the version that worked well, if that can be done.