Intel 630 graphics card bug

Dear colleagues

I know this issue has been discussed before, but I could not find a solution easily.

I have an Intel UHD Graphics 630 card with the latest driver ( Paraview gets lost and messes up the GUI, as reported by other users.

Is there a current, updated, solution or workaround for this issue?

Thank you!

Intel bug.

Four solutions :

  • Use another GPU (eg: nvidia instead of intel)
  • Downgrade your intel driver before
  • Upgrage your intel driver after
  • use mesa instead : paraview-mesa paraview

I know this issue has been discussed before, but I could not find a solution easily.

Please tell me where did you find a discussion without the above answer so I can update it.

Dear Mathieu

Thanks for the prompt response. I had seen exactly the information you posted, but was unable to locate it again. Sorry for that.


  1. I don´t have another GPU in this machine
  2. I could not find out a way to downgrade the driver
  3. The Intel update system says the driver I have is the latest for this board, so I have no idea if I can force an update to a newer driver.
  4. I don´t know how to use mesa in Windows 10. If you can point me in the right direction, that would be great.

Thank you again.

from @cbourcier


  • Download Mesa3d for Windows:
  • Extract it (either with double-click or right-click 7-zip)
  • In the extraction folder of Mesa, go to x64, select and copy opengl32.dll
  • In the extraction folder of Paraview, go to the bin folder and paste opengl32.dll
  • Double-click on paraview.exe

Now Paraview should open without error.



@cbourcier : I think this would fit neatly into a TIps and tricks post. I can do it but feel free to do it if you want :).

Thank you again. Unfortunately, I still have some problems.

On the github site it is not obvious which is the correct download between these two

I downloaded the second one and followed your instructions. However, when I start Paraview I get the following error.
“The code execution cannot proceed because libglapi.dll was not found. Reinstalling the program may fix the problem”.

Any other hints?

Thank you again.

you need to copy the libglapi.dll as well.

However I’ve been playing with it and was not able to obtain anything else than a blackscreen in ParaView.

@cbourcier : which mesa and paraview release were you using exactly ?

@mwestphal, I used Paraview 5.6.0 and Mesa 18.3.4 (there was no libglapi.dll to copy with this version).

I got Paraview 5.8.0 working with Mesa (18 or 20) by overriding GL version in the command line before starting paraview:


@sidnei.paciornik, does it work for you?

1 Like


I got it to run following the override command, but then it shows the same GUI problem as before (see attached image).

To make sure I got it right. To follow what you proposed, must I FIRST, copy the opengl32.dll as previously directed by @mwestphal? Should I also copy the libglapi.dll ?

Thank you.!


I copied both opengl32.dll and libglapi.dll from MESA, did the override, and now it seems to be stable.

Let us see if it stays like this.

Thank you @mwestphal and @cbourcier !!


I had the same problem and finally it was done by setting up a ubuntu OS on a virtual machine (wmware) .